Bug 96237 - XSLT editor does not support messages defined on complex, simple, or built-in types
XSLT editor does not support messages defined on complex, simple, or built-in...
Status: VERIFIED WONTFIX
Product: soa
Classification: Unclassified
Component: XSLT
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Alexey Yarmolenko
issues@soa
: RELNOTE
: 95058 121114 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-21 23:26 UTC by pvarghese
Modified: 2009-01-06 22:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
The project file containing the test case (9.27 KB, application/octet-stream)
2007-02-21 23:28 UTC, pvarghese
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pvarghese 2007-02-21 23:26:34 UTC
XSLT editor does not support messages defined on simple or built-in types

steps to reproduce.
1. Define a wsdl document that has a message defined on a built in data type 
ex: 
    <wsdl:message name="InOutMsg">
        <wsdl:part name="InOutPart" element="xsd:String"/>
    </wsdl:message>
A sample wsdl is available with the project zip attached to this ticket.

2. create a new Request-Reply Service type by selecting this wsdl and pointing
to the request-response operation

3. Observe that the wsdl editor opens up and the mapper view does not have any
message structure shown.

Netbeans build used is :
ide-gavotte-070220_6.zip
from http://balui.sfbay.sun.com/kits/oriondev/gavotte/Build070220_6/
Comment 1 pvarghese 2007-02-21 23:28:28 UTC
Created attachment 38795 [details]
The project file containing the test case
Comment 2 Sergey Lunegov 2007-02-22 06:57:05 UTC
Not stopper for Beta. Will be addressed by FCS.
Comment 3 Alexey Yarmolenko 2007-02-22 08:57:59 UTC
<wsdl:part name="InOutPart" element="xsd:String"/>
Is not a valid declaration.

Should be
<wsdl:part name="InOutPart" type="xsd:string"/>

Please try to run Validate XML on your WSDL files, you will get an error:


C:/Documents and Settings/Alexey/XsltModule32/src/po2la.wsdl:14,8
Error: In part "part1", attribute element's value "xsd:String" is not a valid
xml schema element available in this wsdl file. : Specify a valid schema element
value for element attribute.

C:/Documents and Settings/Alexey/XsltModule32/src/po2la.wsdl:17,8
Error: In part "part1", attribute element's value "xsd:String" is not a valid
xml schema element available in this wsdl file. : Specify a valid schema element
value for element attribute.


Support for type=".." declarations for message parts will be implemented in FCS.
Comment 4 pvarghese 2007-02-22 17:57:21 UTC
My apologies 
Steps to reproduce point 1 in the description was a typo error it should have 
actually been 
    <wsdl:message name="InOutMsg">
        <wsdl:part name="InOutPart" type="xsd:String"/>
    </wsdl:message>

However if you had opened the attached project zip "XsltModule1.zip" and 
looked at the wsdl file InOut.wsdl you would see the message definition as 
    <message name="message1">
        <wsdl:part name="part1" type="xsd:string"/>
    </message>


Comment 5 Alexei Mokeev 2007-03-05 17:27:53 UTC
Removed Beta EP551_WAIVER_APPROVED keyword - we are going forward to FCS.
Comment 6 Alexey Yarmolenko 2007-04-20 10:50:22 UTC
To fix this problem, "source document" tree should be seriously re-worked.
Currently, nodes in this tree is 1-to-1 corrlates with element in AXI model. And
a lot of functions are implemented based on this fact.  To add support for
type="..." definitions, we should add "virtual" node for root elements (virtual
means that they not exists in schema). And all this functions should be
re-written or modified. So, the fix becomes too risky to implement it now.
Comment 7 Sergey Lunegov 2007-04-20 15:23:42 UTC
*** Issue 95058 has been marked as a duplicate of this issue. ***
Comment 8 Alexei Mokeev 2007-08-01 12:59:52 UTC
Guys, 
Any update on this P1 ?
Comment 9 Sergey Lunegov 2007-08-01 13:02:23 UTC
Work in progress. However there is non zero probability will fix it after Beta1.
Comment 10 Vitaly Bychkov 2007-11-05 13:15:33 UTC
*** Issue 121114 has been marked as a duplicate of this issue. ***
Comment 11 Ken Frank 2007-11-05 15:43:43 UTC
there is no warning to user in the wizard or elsewhere about it ?
wouldn't it be that wizard should not complete if this bug situation happens.

in my case, I just kept pressing next in wizard; I realize real
user would know more about how to really do it,
but seems like still should be warning now due to this issue ?
(rather than mysterious warning on design panel)

ken.frank@sun.com
Comment 12 Ken Frank 2007-11-15 21:00:47 UTC
will there be relnote for this ?  I'm adding that keyword; please remove it
if not needed.  My view is from just a user getting started who would
go thru the wizards without customizing the wsdl file yet, but then
they would run into this issue and it could be confusing for them to see the err msg.


ken.frank@sun.com
Comment 13 Sergey Lunegov 2008-01-17 10:54:30 UTC
The XSLT will be on update center so  decreasing priority.
Comment 14 Sergey Lunegov 2008-02-20 09:47:08 UTC
waived
Comment 15 Sergey Lunegov 2008-10-07 10:35:28 UTC
This is related to graphical part of XSLT editor which should reimplemented totally. Marked as WONTFIX.
Comment 16 andyloh 2009-01-06 22:29:20 UTC
The Design View of the XSLT Editor has been removed indefinitely.  Issues related to the former Design View view are no
longer applicable.  GFESB (20090105-0707) does not have the Design View.  Marking this issue as Verified.  


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo