Bug 95995 - javascript in a html file throttles IDE
javascript in a html file throttles IDE
Status: VERIFIED FIXED
Product: web
Classification: Unclassified
Component: HTML Editor
6.x
All Linux
: P1 (vote)
: 6.x
Assigned To: Marek Fukala
Jindrich Sedek
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-20 09:09 UTC by _ hair
Modified: 2009-05-18 10:47 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ hair 2007-02-20 09:09:48 UTC
NetBeans trunk build from yesterday. jdk1.6. linux 2.6.18. gnome.

My velocity templates are registered as html files and are edited accordingly in
netbeans.

A few of my templates contain javascript. When I try to open these files the IDE
throttles and i must force kill it.

At the command line netbeans logs during the throttle:

INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [5918 - 6192].
INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [5918 - 6192].
INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [5918 - 6192].
INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [5918 - 6192].
INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [5918 - 6192].
INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [5918 - 6192].
INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [15757 - 16042].
INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [15757 - 16042].
INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [15757 - 16042].
INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [15757 - 16042].
INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [15757 - 16042].
INFO [org.netbeans.modules.html.editor.coloring.EmbeddingUpdater]: Embedding for
text/javascript created [15757 - 16042].

and on and on...



One examples of the javascript is:

                        <script type="text/javascript"><!--
                            var focusControl = document.forms["sf"].elements["q"];
                            if (focusControl.type != "hidden" &&
!focusControl.disabled) {
                        focusControl.focus();
                            } // -->
                        </script>
Comment 1 Marek Fukala 2007-02-20 09:17:25 UTC
Can you please attach at least of the files causing the problem? If I understand
it right the CPU is on 100% after the html file is opened right? Could you do
some threaddumps during the load? Thanks in advance.
Comment 2 Martin Schovanek 2007-02-27 15:18:21 UTC
Cannot reproduce, please can you attach a steps to reproduce or a sample .html
file? For now marking as incomplete.
Comment 3 Marek Fukala 2007-04-25 14:30:28 UTC
The user hasn't provided the requested steps to reproduce so far, moreover there
have been done some performance fixes in JSP editor recently, so I belive the
problem is already fixed. Closing as fixed, please reopen and add the steps to
reproduce if you can still reproduce on a latest build.
Comment 4 Jindrich Sedek 2007-07-04 09:19:58 UTC
verified
I cannot reproduce neither
NetBeans IDE Dev (Build 200707031200)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo