Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 95947 - Eliminate the JSF 1.1 library (under Sun Binary Code License)
Eliminate the JSF 1.1 library (under Sun Binary Code License)
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSF
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Radko Najman
issues@javaee
:
Depends on: 96143
Blocks: 90674
  Show dependency treegraph
 
Reported: 2007-02-19 15:26 UTC by Petr Jiricka
Modified: 2008-11-03 12:05 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
No such bundle org/netbeans/modules/deployment/deviceanywhere/library/Bundle (4.33 KB, text/plain)
2007-06-27 20:25 UTC, _ potingwu
Details
Another exceptions found when selecting JSF framework (5.48 KB, text/plain)
2007-06-27 21:08 UTC, _ potingwu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2007-02-19 15:26:48 UTC
Currently, the JSF 1.1 library, which is under the Sun Binary Code License, is
included with the IDE. This library should be eliminated, and in cases when it
is needed (e.g. when working with Tomcat), the user should provide the location
of the library. In many cases a JSF implementation is included on the server, so
the user will not need to provide any location.
Comment 1 Radko Najman 2007-05-31 09:30:33 UTC
Added JSF 1.2 library and modified JSF support to use it.

Checking in web/jsf12/nbproject/project.xml;
/cvs/web/jsf12/nbproject/project.xml,v  <--  project.xml
initial revision: 1.1
done
RCS file: /cvs/web/jsf12/nbproject/.cvsignore,v
done
Checking in web/jsf12/nbproject/.cvsignore;
/cvs/web/jsf12/nbproject/.cvsignore,v  <--  .cvsignore
initial revision: 1.1
done
RCS file: /cvs/web/jsf12/nbproject/project.properties,v
done
Checking in web/jsf12/nbproject/project.properties;
/cvs/web/jsf12/nbproject/project.properties,v  <--  project.properties
initial revision: 1.1
done
Checking in web/external/build.xml;
/cvs/web/external/build.xml,v  <--  build.xml
new revision: 1.44; previous revision: 1.43
done
Checking in web/external/.cvsignore;
/cvs/web/external/.cvsignore,v  <--  .cvsignore
new revision: 1.35; previous revision: 1.34
done
RCS file: /cvs/web/external/jsf-1.2.zip,v
done
Checking in web/external/jsf-1.2.zip;
/cvs/web/external/jsf-1.2.zip,v  <--  jsf-1.2.zip
initial revision: 1.1
done
Checking in
web/jsf/src/org/netbeans/modules/web/jsf/wizards/JSFConfigurationPanelVisual.form;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/wizards/JSFConfigurationPanelVisual.form,v
 <--  JSFConfigurationPanelVisual.form
new revision: 1.6; previous revision: 1.5
done
Checking in web/jsf/src/org/netbeans/modules/web/jsf/wizards/Bundle.properties;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/wizards/Bundle.properties,v  <-- 
Bundle.properties
new revision: 1.9; previous revision: 1.8
done
Checking in
web/jsf/src/org/netbeans/modules/web/jsf/wizards/JSFConfigurationPanel.java;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/wizards/JSFConfigurationPanel.java,v
 <--  JSFConfigurationPanel.java
new revision: 1.7; previous revision: 1.6
done
Checking in
web/jsf/src/org/netbeans/modules/web/jsf/wizards/JSFConfigurationPanelVisual.java;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/wizards/JSFConfigurationPanelVisual.java,v
 <--  JSFConfigurationPanelVisual.java
new revision: 1.10; previous revision: 1.9
done
Checking in nbbuild/cluster.properties;
/cvs/nbbuild/cluster.properties,v  <--  cluster.properties
new revision: 1.264; previous revision: 1.263
done
Checking in web/jsf/src/org/netbeans/modules/web/jsf/JSFFrameworkProvider.java;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/JSFFrameworkProvider.java,v  <-- 
JSFFrameworkProvider.java
new revision: 1.17; previous revision: 1.16
done
RCS file: /cvs/web/jsf/src/org/netbeans/modules/web/jsf/JSFUtils.java,v
done
Checking in web/jsf/src/org/netbeans/modules/web/jsf/JSFUtils.java;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/JSFUtils.java,v  <--  JSFUtils.java
initial revision: 1.1
done
RCS file: /cvs/web/jsf12/src/org/netbeans/modules/web/jsf12/layer.xml,v
done
Checking in web/jsf12/src/org/netbeans/modules/web/jsf12/layer.xml;
/cvs/web/jsf12/src/org/netbeans/modules/web/jsf12/layer.xml,v  <--  layer.xml
initial revision: 1.1
done
RCS file: /cvs/web/jsf12/src/org/netbeans/modules/web/jsf12/Bundle.properties,v
done
Checking in web/jsf12/src/org/netbeans/modules/web/jsf12/Bundle.properties;
/cvs/web/jsf12/src/org/netbeans/modules/web/jsf12/Bundle.properties,v  <-- 
Bundle.properties
initial revision: 1.1
done
RCS file: /cvs/web/jsf12/src/org/netbeans/modules/web/jsf12/jsf12.xml,v
done
Checking in web/jsf12/src/org/netbeans/modules/web/jsf12/jsf12.xml;
/cvs/web/jsf12/src/org/netbeans/modules/web/jsf12/jsf12.xml,v  <--  jsf12.xml
initial revision: 1.1
done
Checking in web/jsf/nbproject/project.xml;
/cvs/web/jsf/nbproject/project.xml,v  <--  project.xml
new revision: 1.21; previous revision: 1.20
done
RCS file: /cvs/web/jsf12/build.xml,v
done
Checking in web/jsf12/build.xml;
/cvs/web/jsf12/build.xml,v  <--  build.xml
initial revision: 1.1
done
RCS file: /cvs/web/jsf12/.cvsignore,v
done
Checking in web/jsf12/.cvsignore;
/cvs/web/jsf12/.cvsignore,v  <--  .cvsignore
initial revision: 1.1
done
RCS file: /cvs/web/jsf12/manifest.mf,v
done
Checking in web/jsf12/manifest.mf;
/cvs/web/jsf12/manifest.mf,v  <--  manifest.mf
initial revision: 1.1
done
Comment 2 Radko Najman 2007-05-31 09:52:34 UTC
... and

Checking in deps.txt;
/cvs/ide/golden/deps.txt,v  <--  deps.txt
new revision: 1.586; previous revision: 1.585
done
Checking in modules.txt;
/cvs/ide/golden/modules.txt,v  <--  modules.txt
new revision: 1.154; previous revision: 1.153
done
Checking in files-layout.txt;
/cvs/ide/golden/files-layout.txt,v  <--  files-layout.txt
new revision: 1.254; previous revision: 1.253
done
Comment 3 Radko Najman 2007-05-31 13:07:26 UTC
Removed JSF 1.1 library.

Checking in jsf/nbproject/project.properties;
/cvs/web/jsf/nbproject/project.properties,v  <--  project.properties
new revision: 1.17; previous revision: 1.16
done
Checking in external/build.xml;
/cvs/web/external/build.xml,v  <--  build.xml
new revision: 1.45; previous revision: 1.44
done
Checking in external/.cvsignore;
/cvs/web/external/.cvsignore,v  <--  .cvsignore
new revision: 1.36; previous revision: 1.35
done
Removing external/jsf-license.txt;
/cvs/web/external/jsf-license.txt,v  <--  jsf-license.txt
new revision: delete; previous revision: 1.2
done
Removing external/jsf-1.1.zip;
/cvs/web/external/jsf-1.1.zip,v  <--  jsf-1.1.zip
new revision: delete; previous revision: 1.2
done
Checking in jsf/src/org/netbeans/modules/web/jsf/resources/layer.xml;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/resources/layer.xml,v  <--  layer.xml
new revision: 1.13; previous revision: 1.12
done
Checking in jsf/src/org/netbeans/modules/web/jsf/resources/Bundle.properties;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/resources/Bundle.properties,v  <--
 Bundle.properties
new revision: 1.8; previous revision: 1.7
done
Removing jsf/src/org/netbeans/modules/web/jsf/resources/jsf.xml;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/resources/jsf.xml,v  <--  jsf.xml
new revision: delete; previous revision: 1.5
done
Checking in jsf/build.xml;
/cvs/web/jsf/build.xml,v  <--  build.xml
new revision: 1.7; previous revision: 1.6
done

Comment 4 Petr Pisl 2007-06-01 15:21:14 UTC
I looked at the implementation and there are my comments:

PP01: If there is not registered any jsf library in the IDE, the registered
libraries radio button should be disabled. In the current state there is
disabled only the combobox (which is empty) and when you select the Registered
libraries the combobox is enabled. 

PP02: The Finish button should be enabled only when:
A registered library is selected or when correct data for creating new jsf
librarys are entered or user choose Don't append any library. 

PP03: Now there is not check, whether the forlder for creating jsf library are
correct. 

PP04: There is not recognized the JSF 1.2 library, which is already registered
in the Library manager. 

Comment 5 Petr Pisl 2007-06-13 09:12:38 UTC
Reopening the issue.
Comment 6 Petr Jiricka 2007-06-13 13:00:28 UTC
PJ01: Label "Don't append any library" should be changed to "Do not append any library." The norm is not to abbreviate
labels in the UI.

Comment 7 _ potingwu 2007-06-14 00:51:59 UTC
The removing of JSF 1.1 library causes Unresolved Reference Problem ("jsf" library could not be found) when trying to
open a web+JSF framework project created by NetBeans 5.5! Do we have good solution for the users?

Creating a users defined JSF 1.1 library looks like not an one-step trivial task. They needs to know what jar files to
include and somehow know how NetBeans Library Manager works. Not difficult for >1 year NetBeans users, but for new
learners, it is not easy.

I found users can virtually create a new JSF 1.1 project and create the JSF 1.1 library under the new Libraries tab.
Then opening their old NetBeans 5.5 JSF 1.1 projects can just resolve the missing references by using this new library.
But again, the workaround is not clear enough too.
Comment 8 Petr Pisl 2007-06-14 09:53:37 UTC
This is a problem and we knew about this regression. But the removing JSF 1.1 from standard distribution is necessary
step to get NetBeans into linux distributions. 

Basically there is not a direct solution in the current build. The JSF 1.1 library should be on the autoupdate and the
resolving missing JSF 1.1 should be handled better.
Comment 9 Radko Najman 2007-06-22 13:16:54 UTC
A few mentioned wizard's issues addressed.

Library tab initialization needs to be improved to better set initial values.

Checking in JSFConfigurationPanelVisual.form;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/wizards/JSFConfigurationPanelVisual.form,v  <-- 
JSFConfigurationPanelVisual.form
new revision: 1.7; previous revision: 1.6
done
Checking in JSFConfigurationPanelVisual.java;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/wizards/JSFConfigurationPanelVisual.java,v  <-- 
JSFConfigurationPanelVisual.java
new revision: 1.11; previous revision: 1.10
done
Checking in Bundle.properties;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/wizards/Bundle.properties,v  <--  Bundle.properties
new revision: 1.10; previous revision: 1.9
done
Comment 10 Radko Najman 2007-06-25 14:35:36 UTC
Improved error messages.

Checking in JSFConfigurationPanelVisual.java;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/wizards/JSFConfigurationPanelVisual.java,v  <-- 
JSFConfigurationPanelVisual.java
new revision: 1.12; previous revision: 1.11
done
Checking in Bundle.properties;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/wizards/Bundle.properties,v  <--  Bundle.properties
new revision: 1.11; previous revision: 1.10
done
Comment 11 Radko Najman 2007-06-27 08:36:23 UTC
Improved initial libraries settings.

Checking in JSFConfigurationPanelVisual.java;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/wizards/JSFConfigurationPanelVisual.java,v  <-- 
JSFConfigurationPanelVisual.java
new revision: 1.13; previous revision: 1.12
done
Comment 12 _ potingwu 2007-06-27 20:24:39 UTC
After update to the new 'libraries init', I got the following exceptions (attached):
    No such bundle org/netbeans/modules/deployment/deviceanywhere/library/Bundle
Comment 13 _ potingwu 2007-06-27 20:25:29 UTC
Created attachment 44482 [details]
No such bundle org/netbeans/modules/deployment/deviceanywhere/library/Bundle
Comment 14 _ potingwu 2007-06-27 21:08:32 UTC
Created attachment 44483 [details]
Another exceptions found when selecting JSF framework
Comment 15 _ potingwu 2007-06-28 00:06:14 UTC
After a clean cvs and build, I don't see the following error! Sorry for the false alarm!
    No such bundle org/netbeans/modules/deployment/deviceanywhere/library/Bundle
Comment 16 Radko Najman 2007-06-28 08:51:57 UTC
Trying to prevent NPE. (I cannot reproduce it, describe steps to reproduce next time, please)

Checking in JSFConfigurationPanelVisual.java;
/cvs/web/jsf/src/org/netbeans/modules/web/jsf/wizards/JSFConfigurationPanelVisual.java,v  <-- 
JSFConfigurationPanelVisual.java
new revision: 1.15; previous revision: 1.14
done
Comment 17 martin_zmrhal 2008-11-03 12:05:30 UTC
verified

Product Version: NetBeans IDE Dev (Build 200811011401)
Java: 1.6.0_10-rc2; Java HotSpot(TM) Client VM 11.0-b15
System: Linux version 2.6.24-21-generic running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo