Bug 95293 - Unable to run webstart project on Win XP
Unable to run webstart project on Win XP
Status: RESOLVED FIXED
Product: projects
Classification: Unclassified
Component: Java Webstart
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Milan Kubec
issues@projects
: SPACE_IN_PATH
: 98892 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-12 16:06 UTC by Jaromir Uhrik
Modified: 2007-04-27 19:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot attached... (5.34 KB, image/png)
2007-02-12 16:07 UTC, Jaromir Uhrik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2007-02-12 16:06:06 UTC
NetBeans IDE Dev (Build 200702111900)
1.5.0_07; Java HotSpot(TM) Client VM 1.5.0_07-b02
Windows XP version 5.1 running on x86
en_US (nb); Cp1252

1.Create new j2se project
2.In this project create new JFrame form and make it to be main class of the project
3.In project properties set enabled checkboxes "Enable Web Start" and "Allow
Offline" in panel related to "Application|Web Start" node
4.Run project and the Invalid Argument Error dialog appears (see attached
screenshot). The details contain following output:
==================================================
General:
========
An error occurred while launching/running the application.

Category: Invalid Argument Error

Too many arguments supplied: {C:\My,
Documents\NetBeansProjects\JavaApplication15\dist/launch.jnlp }
==================================================
Exception:
==========
TooManyArgumentsException[ Too many arguments supplied: {C:\My,
Documents\NetBeansProjects\JavaApplication15\dist/launch.jnlp }]
	at com.sun.javaws.Main.launchApp(Main.java:174)
	at com.sun.javaws.Main.main(Main.java:136)

==================================================
Comment 1 Jaromir Uhrik 2007-02-12 16:07:48 UTC
Created attachment 38387 [details]
Screenshot attached...
Comment 2 Milan Kubec 2007-02-23 12:51:45 UTC
Space in path is not handled correctly.
Comment 3 Milan Kubec 2007-03-26 11:36:15 UTC
*** Issue 98892 has been marked as a duplicate of this issue. ***
Comment 4 Joshua Marinacci 2007-03-26 17:13:49 UTC
This bug is probably because webstart assumes the URL will be properly encoded as it would if the URL 
was a live link on a webserver. We should probably encode the URL the same way within NetBeans.
Comment 5 Milan Kubec 2007-03-27 08:09:12 UTC
Yes, that's probably the problem, I hope it can be fixed using ant processing.
Comment 6 Milan Kubec 2007-04-27 08:41:11 UTC
Fixed. The problem actually wasn't encoding of the codebase attribute in jnlp
file (which is correct), but not using " around exec arguments in ant script.

Checking in jnlp-impl.xml_;
/cvs/javawebstart/src/org/netbeans/modules/javawebstart/resources/jnlp-impl.xml_,v
 <--  jnlp-impl.xml_
new revision: 1.3; previous revision: 1.2
done
Comment 7 Milan Kubec 2007-04-27 19:29:08 UTC
Better fix is to use <arg file="">

Checking in jnlp-impl.xml_;
/cvs/javawebstart/src/org/netbeans/modules/javawebstart/resources/jnlp-impl.xml_,v
 <--  jnlp-impl.xml_
new revision: 1.4; previous revision: 1.3
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo