Bug 95256 - Cannot create ruby app project; NPE in new project wizard
Cannot create ruby app project; NPE in new project wizard
Status: VERIFIED DUPLICATE of bug 95184
Product: ruby
Classification: Unclassified
Component: Code
6.x
PC Linux
: P1 (vote)
: 6.x
Assigned To: Torbjorn Norbye
issues@ruby
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-12 13:30 UTC by Tomas Danek
Modified: 2007-07-03 14:47 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2007-02-12 13:30:14 UTC
..after attempt to create new Ruby application,in step #2 of wizard, hit finish
button: 


java.lang.NullPointerException
	at org.openide.loaders.DataObject.setTemplate(DataObject.java:321)
	at org.openide.loaders.FileEntry$Format.createFromTemplate(FileEntry.java:192)
	at
org.openide.loaders.MultiDataObject.handleCreateFromTemplate(MultiDataObject.java:683)
	at
org.netbeans.modules.gsf.GsfDataObject.handleCreateFromTemplate(GsfDataObject.java:95)
	at org.openide.loaders.DataObject$CreateAction.run(DataObject.java:1173)
	at
org.openide.loaders.DataObjectPool$1WrapAtomicAction.run(DataObjectPool.java:202)
	at org.openide.filesystems.EventControl.runAtomicAction(EventControl.java:98)
	at org.openide.filesystems.FileSystem.runAtomicAction(FileSystem.java:471)
	at org.openide.loaders.DataObjectPool.runAtomicAction(DataObjectPool.java:214)
	at org.openide.loaders.DataObject.invokeAtomicAction(DataObject.java:796)
	at org.openide.loaders.DataObject.createFromTemplate(DataObject.java:728)
	at org.openide.loaders.DataObject.createFromTemplate(DataObject.java:708)
	at
org.netbeans.modules.ruby.rubyproject.RubyProjectGenerator.createMainClass(RubyProjectGenerator.java:336)
	at
org.netbeans.modules.ruby.rubyproject.RubyProjectGenerator.createProject(RubyProjectGenerator.java:76)
	at
org.netbeans.modules.ruby.rubyproject.ui.wizards.NewRubyProjectWizardIterator.instantiate(NewRubyProjectWizardIterator.java:131)
	at
org.openide.loaders.TemplateWizard$InstantiatingIteratorBridge.instantiate(TemplateWizard.java:994)
	at org.openide.loaders.TemplateWizard.handleInstantiate(TemplateWizard.java:572)
	at
org.openide.loaders.TemplateWizard.instantiateNewObjects(TemplateWizard.java:393)
	at
org.openide.loaders.TemplateWizardIterImpl.instantiate(TemplateWizardIterImpl.java:231)
	at
org.openide.loaders.TemplateWizardIteratorWrapper.instantiate(TemplateWizardIteratorWrapper.java:143)
	at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1333)
	at org.openide.WizardDescriptor.callInstantiate(WizardDescriptor.java:1290)
	at org.openide.WizardDescriptor.access$1600(WizardDescriptor.java:96)
	at org.openide.WizardDescriptor$Listener$2$1.run(WizardDescriptor.java:1846)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:541)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:963)
Comment 1 Tomas Danek 2007-02-12 13:34:04 UTC
NetBeans IDE Dev (Build 200702111900)
1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105
Linux version 2.6.17-10-generic running on i386
cs_CZ (nb); UTF-8

+ #87 from nbextras
Comment 2 Martin Krauskopf 2007-02-12 14:00:38 UTC
Would be nice to have some tests for such regressions ;) Cf.
apisupport/project/test/unit/src/o/n/m/apisupport/project/NbModuleProjectGeneratorTest.java
or similar ones in other project types (j2se).
Comment 3 Torbjorn Norbye 2007-02-12 14:48:16 UTC
I just noticed this myself yesterday and filed a bug against openide/datasystems
- issue 95184. That issue was just marked as fixed - I will close this issue as
a duplicate.

*** This issue has been marked as a duplicate of 95184 ***
Comment 4 Tomas Danek 2007-05-24 11:17:31 UTC
verified dupl.
Comment 5 Jiri Kovalsky 2007-07-03 14:16:38 UTC
Reassigning this issue to newly created 'ruby' component.
Comment 6 Jiri Kovalsky 2007-07-03 14:47:16 UTC
Changing target milestone of all resolved Ruby issues from TBD to 6.0 Beta 1 build.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo