Bug 95058 - Cannot create XSLT using RPC Literal binding subtype
Cannot create XSLT using RPC Literal binding subtype
Status: CLOSED DUPLICATE of bug 96237
Product: soa
Classification: Unclassified
Component: XSLT
5.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: Alexey Yarmolenko
issues@soa
EP551_BETA_RN
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-09 11:25 UTC by Andrei Chistiakov
Modified: 2007-09-05 10:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Chistiakov 2007-02-09 11:25:48 UTC
Reproduced in build 070208_27.

To reproduce the bug:
- create the following schemas
<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
            targetNamespace="http://xml.netbeans.org/schema/newXMLSchema1"
            xmlns:tns="http://xml.netbeans.org/schema/newXMLSchema1"
            elementFormDefault="qualified">
    <xsd:element name="inputString" type="tns:InputStringType"></xsd:element>
    <xsd:complexType name="InputStringType">
        <xsd:sequence>
            <xsd:element name="value" type="xsd:string"></xsd:element>
        </xsd:sequence>
    </xsd:complexType>
</xsd:schema>

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
            targetNamespace="http://xml.netbeans.org/schema/newXMLSchema2"
            xmlns:tns="http://xml.netbeans.org/schema/newXMLSchema2"
            elementFormDefault="qualified">
    <xsd:element name="outputString" type="tns:OutputStringType"></xsd:element>
    <xsd:complexType name="OutputStringType">
        <xsd:sequence>
            <xsd:element name="value" type="xsd:string"></xsd:element>
        </xsd:sequence>
    </xsd:complexType>
</xsd:schema>

- create WSDL file. Use RPC Literal binding, InputStringType input type,
OutputStringType output type, SOAP binding type, RPC Literal binding subtype;
- create XSLT Service using the WSDL file.

It's impossible to define XSL transformation of InputStringType to
OutputStringType using Mapper.
Comment 1 Alexey Yarmolenko 2007-02-14 16:43:08 UTC
The fix is quiet tricky, because current source/target tree are designed to work
with AXIOM element tree. In case of RPC/Literal service, message part
declaration uses type=... style. So, we have to create a fictive root for our
source document tree. This may cause a lot of unpredictable side effects. 
Comment 2 Alexei Mokeev 2007-02-16 11:28:40 UTC
There were no objections in 48 hours since the waiver was requested.
EP551_WAIVER_APPROVED
Comment 3 astashkova 2007-02-16 17:11:04 UTC
Added to NB Enterprise Pack Release Notes 5.5.1 Beta
(http://nbstaging.czech.sun.com/community/releases/55/1/entpack_relnotes.html#95058).

Workaround (if any) needed.
Comment 4 Alexei Mokeev 2007-03-05 17:24:26 UTC
Removed Beta EP551_WAIVER_APPROVED keyword - we are going forward to FCS.
Comment 5 gaikokujin 2007-03-16 20:06:50 UTC
Per:

Added to NB Enterprise Pack Release Notes 5.5.1 Beta
(http://nbstaging.czech.sun.com/community/releases/55/1/entpack_relnotes.html#95058).

Not finding any reference in the current NB Enterprise Pack Release Notes 5.5.1
Beta:

http://www.netbeans.org/community/releases/55/entpack_relnotes.html#known_issues

Comment 6 gaikokujin 2007-03-16 20:07:40 UTC
Per:

Added to NB Enterprise Pack Release Notes 5.5.1 Beta
(http://nbstaging.czech.sun.com/community/releases/55/1/entpack_relnotes.html#95058).

Not finding any reference in the current NB Enterprise Pack Release Notes 5.5.1
Beta:

http://www.netbeans.org/community/releases/55/entpack_relnotes.html#known_issues

Comment 7 astashkova 2007-03-19 14:02:42 UTC
The issue is release notes at
http://nbstaging.czech.sun.com/community/releases/55/1/ep-relnotes.html#95058
Comment 8 Andrei Chistiakov 2007-03-19 14:22:33 UTC
The mentioned URL 
http://www.netbeans.org/community/releases/55/entpack_relnotes.html#known_issues
is related to Ent Pack 5.5. Please refer to Ent Pack 5.5.1 Beta release notes at
http://www.netbeans.org/community/releases/55/1/ep-relnotes.html#limitations.
Comment 9 Sergey Lunegov 2007-04-20 15:23:43 UTC

*** This issue has been marked as a duplicate of 96237 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo