Bug 94316 - Lost keyboard focus (no longer accept keyboard input)
Lost keyboard focus (no longer accept keyboard input)
Status: RESOLVED DUPLICATE of bug 97249
Product: platform
Classification: Unclassified
Component: Window System
5.x
Other Linux
: P3 (vote)
: 6.x
Assigned To: David Simonek
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-05 09:24 UTC by kiyut
Modified: 2008-12-22 11:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kiyut 2007-02-05 09:24:03 UTC
Netbeans IDE 5.5 on Linux / Fedora Core 6 often lost keyboard focus (no longer
accept keyboard input), so that I unable to type anything on the editor, on the
dialog, etc. But mouse still working, menu working, etc, everything is working,
only it no longer accept keyboard input.

Netbeans: 5.5
OS = Linux Fedora Core 6
Java = Jdk 1.5.0_10

There are no particular steps to reproduce the problem, but it happen often (not
always) usually after using Netbeans for 1 hours.

My current solutions is just close Netbeans and reopen again
Comment 1 David Simonek 2007-02-16 11:47:17 UTC
Sorry, but we need reproductible steps in order to fix the bug. While I fully
believe you that it happens and that it's real problem, we can't reproduce it
here and are not able to do anything with the bug.

It may also be JDK x OS bug, so please - try to run it under various JDK
versions, perhpas problem is specific to only some JDK versions. Or maybe your
window manager is set to some specific unusual configuration. Also try to watch
after which steps keyboard goes frozen. We need to reproduce, otherwise we are
helpless.

Please reopen with additional info, thanks. 
Comment 2 jeb 2007-04-04 11:37:14 UTC
I have also encountered this problem, and I think I have discovered how to
reproduce it.  My configuration:

Netbeans: 5.5 
OS = Linux Fedora Core 6 (2.6.20-1.2933.fc6)
KDE = 3.5.6-0.3.fc6 Fedora-Core
Java = Jdk 1.5.0_11

Steps to reproduce:

A. First method

1. Open NB 5.5 full screen
2. Open a java file in editor
3. Use arrow keys to move around and make sure all is well
4. Select "Lock Session" from KDE menu to invoke screensaver
5. Enter password and select "Unlock" to re-enter session
6. Click in NB editor window
7. Attempt to use arrow keys (or any keys) - no response
8. Click into another NB window (e.g. Project) and then back in editor
9. Keys now work

B. Second method

1-3 as above
4. Open KDevelop (from wherever it is in your KDE menus) full screen so that it
COMPLETELY covers NB window
5. Activate NB from taskbar
6-9 as above

The problem occasionally manifests itself when the NB window is completely
covered by some other applications, but the two cases above are the only
consistent failures I have found.  FWIW, I have observed similar behaviour in
SQL Workbench/J, which is built on the NB platform (not sure which version).
Comment 3 shal 2007-04-12 07:43:19 UTC
I lost keyboard focus in the same way (editor, dialog box ..). 

Netbeans: 5.5
OS: Mandriva Linux 2007
Java: Jdk 1.6.0

I have tried to reproduce the problemn by following the steps given by jeb but
it did not work. 

Comment 4 jeb 2007-04-17 13:38:32 UTC
Removing SCIM turned out to be a solution for me.  Killing/disabling SCIM didn't
work for me, but was reported to work for others in a similar thread for IDEA:  

http://www.jetbrains.net/jira/browse/IDEADEV-2359
Comment 5 zappes 2007-05-10 09:13:35 UTC
Same issue here

Netbeans 5.5, Ubuntu 7.04, Gnome with desktop effects (compiz) enabled, Sun JDK
1.6, no SCIM that I'm aware of

I often encounter the error whenever the focus in netbeans changes, e.g. if I
perform some kind of refactoring which opens the refactoring preview window. One
workaround is to open any java source file, wait for a few seconds and close
that file again - after that, the keyboard will work for a while. The problem is
not limited to focus changes in Netbeans itself, though - it also occurs when I
change virtual desktops, use ALT+TAB to cycle through windows etc.

The unnerving part is that the problem is not really reproducable. Doing one of
the described things may or may not trigger the problem, propably depending on
the timing of my actions.
Comment 6 nawaman 2007-05-17 07:39:22 UTC
Hi,
I encounter the same problem.
I am using Ubuntu 7.04 with Netbeans 5 .5 and JVM 1.6.0_01-b06.
After trying different things, I am pretty sure that I can reproduce it by
simply press Ctrl+F or any dialog.
I also found that Just simple click the menu "Help -> Help Content" will simply
bring me back the keyboard focus.
Hope that this will be useful to someone while still wait for a better solution.
Nawa Man
Comment 7 malcolmcarmen 2007-05-21 23:03:48 UTC
I too suffer from this same issue. As previously mentioned by someone else, I
can reproduce this by using the find dialog (ctrl+f), or most any other dialog
for that matter (such as refactoring). Once I do this, the editor will no longer
respond to keystrokes. To get control back, I normally click another open
document tab, which will return control right away.

NetBeans 5.5
Java: build 1.6.0-b105 (I also previously ran netbeans using the 1.5 JDK and the
issue still existed)
OS: Ubuntu 6.10 (Edgy Eft) using Gnome/metacity

I believe I started netbeans up in KDE and also suffered the same problem, so I
don't think it is the window manager. Somewhere else, I saw it recommended that
the package "scim" be removed, but this did not help.
Comment 8 bludhound 2007-06-08 04:36:28 UTC
I've encountered this on Ubuntu Fiesty too, with Desktop Effects both on and
off. All I need to do is to switch to other windows via Alt-Tab a couple of
times. If I switch using mouse input, the problem would not surface.

It's really annoying as I usually switch between Netbeans and Firefox for web
development.

I'm not sure if I'm going through the proper channel, but I'd like to note that
this occurs on Netbeans 5.5.1 too.
Comment 9 steve_morris 2007-06-09 01:27:57 UTC
I also get this problem in Mandriva Linux with Netbeans 5.5.1, KDE 3.5.7 and
Java 1.6.0.0.

Also I am having problems under Linux with the Netbeans editor disabling
keyboard input within it, and the only way around it is to shut it down and
restart it. This problem is inconsistent in that sometimes when input is
disabled in the component properties window I can click on the ellipsis next to
the property to bring up the property editor and use keyboard input in there,
but at other times keyboard input is disabled in the property editor as well.
When I encounter this problem keyboard input is disabled in the source editor
also and the keyboard shortcut for file saving is disabled as well. A Netbeans
restart usually rectifies the problem for a couple of minutes and then it
reoccurs, so I am continually having to stop and start Netbeans in order to do
anything. Other applications have no problems with keyboard input, even when
Netbeans is.
Comment 10 steve_morris 2007-06-17 10:05:29 UTC
I have tried the VWP functions under Netbeans V6 Milestone 9 and the problems exhibited with Netbeans V5.5.1 appear to
have been rectified.
Comment 11 gestalt 2007-06-19 09:14:01 UTC
it probably has s.th. to do with runnung AIGLX/XGL using the "AWT_TOOLKIT=MToolkit" export to make it work with Java6
Comment 12 David Simonek 2007-09-03 13:42:15 UTC
Issue is very similar to 97249, making duplicate as 97249 contains some extra info and links to entered JDK  bug and JDK
engineer. Please make your further comments about bug occurrence and reproducible steps in 97249, thanks.

*** This issue has been marked as a duplicate of 97249 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo