Bug 94193 - bean nodes disappear from Outline if save the source file after adding a property or class
bean nodes disappear from Outline if save the source file after adding a prop...
Status: RESOLVED WONTFIX
Product: obsolete
Classification: Unclassified
Component: visualweb
5.x
All All
: P3 (vote)
: 6.x
Assigned To: _ sandipchitale
issues@obsolete
:
: 98577 106148 111100 111909 116443 (view as bug list)
Depends on: 96196 90907
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-03 00:31 UTC by bugbridge
Modified: 2008-01-18 21:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2007-02-03 00:31:21 UTC
Original status: 1-Dispatched; Suggested Status: NEW


Description:
Steps:
1. install nb5.5 build 200611220100, vwp build 061121_4
2. create a visual web application
3. add a property or class from Outline -> SessionBean1 or ApplicationBean1 or
RequestsBean1
For instance, add a property to SessionBean1. 
Set the Type "a" for instance. That means "a" can be user's class that need to
be imported later.
4. open SessionBean1.java, then save.
5. open another Page1.jsp in another visual application.
6. switch to the first Page1.jsp

Result:
SessionBean node disappears from the Outline window. Refer to the screenshot
attached.
Closing the project and IDE, and removing the user dir don't make difference.

* This doesn't happen in Leopard.
Comment 1 Peter Zavadsky 2007-02-21 00:12:00 UTC
Can't try out now. There is another issue preventing to add any property into
the beans now.
Comment 2 Peter Zavadsky 2007-02-21 18:40:11 UTC
Currently this issue is blocked by the fact, that the java node misses its sub
nodes with the needed new types (they can't be retrieved now via the current hack).
Comment 3 Peter Zavadsky 2007-02-21 18:41:18 UTC
See blocking issue #96196.
Comment 4 Peter Zavadsky 2007-03-22 18:55:21 UTC
See also issue #90907.

This is not gonna by fixed for 6.0, because of the blocking issues.
Comment 5 _ sandipchitale 2007-03-22 22:36:08 UTC
*** Issue 98577 has been marked as a duplicate of this issue. ***
Comment 6 Peter Zavadsky 2007-06-04 18:08:11 UTC
Adding 6.0 waiver request.
Comment 7 Peter Zavadsky 2007-06-08 19:25:03 UTC
*** Issue 106148 has been marked as a duplicate of this issue. ***
Comment 8 Petr Hrebejk 2007-06-13 10:46:11 UTC
IMO the issue should be solved a different way. Adding more and more nodes under the Java node just clutters the GUI.
EJB should have extra tab in the navigator which will permit for doing EJB specific operations. (So should do JavaBeans
after resurrected)

Comment 9 Peter Zavadsky 2007-07-25 12:14:13 UTC
No objections long time, changing to waiver approved.
Comment 10 Peter Zavadsky 2007-08-01 07:07:03 UTC
*** Issue 111100 has been marked as a duplicate of this issue. ***
Comment 11 Peter Zavadsky 2007-08-07 17:14:22 UTC
*** Issue 111909 has been marked as a duplicate of this issue. ***
Comment 12 Joseph Silber 2007-09-10 13:00:43 UTC
Release note added
Comment 13 Peter Zavadsky 2007-09-24 18:15:20 UTC
*** Issue 116443 has been marked as a duplicate of this issue. ***
Comment 14 Peter Zavadsky 2008-01-18 17:15:00 UTC
OK, there are more and more complains about this. I am passing this issue to insync, where it belongs (the node
implementation is there).
Comment 15 _ sandipchitale 2008-01-18 21:51:07 UTC
The Add Property in Outline window is no longer supported in 6.0 because of removal of underlying beans module support.

Definitley not a P2.

Thirdly the SessionBean1 is disappearing because of the user did not import the "a" which results in the syntax error.
The SessionBean node and the tab does indicate that with a badge. Because of the syntax error Insync cannot model the
SessionBean. Importing the "a" fixes the issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo