Bug 94151 - Invalid dialog when table is added to SessionBean1 second time. Further adding does nothing at all
Invalid dialog when table is added to SessionBean1 second time. Further addin...
Status: VERIFIED FIXED
Product: obsolete
Classification: Unclassified
Component: visualweb
5.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: John Baker
issues@obsolete
release601_fixes_candidate1 release60...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-02 21:55 UTC by bugbridge
Modified: 2008-02-20 18:18 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Dialog showing problem (43.87 KB, image/jpeg)
2007-02-02 21:57 UTC, _ jimdavidson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2007-02-02 21:55:19 UTC
Original submitter: mikhailmatveev

Description:
1. Create project.
2. DnD PERSON table to SessionBean1 in outline.
3. DnD PERSON table to SessionBean1 in outline again.
Result: invalid dialog appears (pic attached)

Comments: (jimdavidson)
Dropping a table onto the Session Bean has problems that don't occur when it is
dropped onto the form.  They're still present in Shortfin.  Not a big deal.


Evaluation: (jbaker)
Can no longer reproduce. I believe some fixes were made in insync.

When I drop a 2nd PERSON table onto the SessionBean the 
"Add New Data Provider with RowSet for Table PERSON" dialog opens
appropriately.
If Cancelled then the TRIP table is dropped onto the SessionBean then
a tripDataProvider and tripRowSet are added as expected

Evaluation (Entry 2): (mikhailmatveev)
Still reproducible exactly as described in last build.

Evaluation (Entry 3): (jbaker)
The description was not clear - no error dialog opens, just the dialog shows
2 entries for person 

Also another bug had been filed for the same issue
Comment 1 _ jimdavidson 2007-02-02 21:57:27 UTC
Created attachment 37985 [details]
Dialog showing problem
Comment 2 John Baker 2007-03-01 02:12:11 UTC
Minor bug, may not have time to fix for 6.0
Comment 3 John Baker 2007-12-12 03:49:10 UTC
Lots of original logic errors to be fixed
Comment 4 John Baker 2007-12-12 22:14:49 UTC
Fixed
cvs commit: Examining visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/customizers
Checking in visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/customizers/RowSetSelection.form;
/cvs/visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/customizers/RowSetSelection.form,v 
<--  RowSetSelection.form
new revision: 1.2; previous revision: 1.1
done
Checking in visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/customizers/RowSetSelection.java;
/cvs/visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/customizers/RowSetSelection.java,v 
<--  RowSetSelection.java
new revision: 1.3; previous revision: 1.2
done
Comment 5 Roman Mostyka 2008-01-14 18:34:59 UTC
Verified with NetBeans IDE Dev (Build 200801140000). Tried with NetBeans IDE 6.0.1 dev (Build 200801140000), but not
successful.
Comment 6 John Baker 2008-01-14 19:19:46 UTC
So, the bug is still there in NetBeans IDE 6.0.1?

Then there is a separate branch for NetBeans IDE 6.0.1 ?

I only integrated the fix into the trunk
Comment 7 Karthikeyan Rajeswaran 2008-01-14 21:20:30 UTC
If fixed in the trunk, then the bug will still be in 6.0.1. (And there is no need to fix it in 601 branch, because the
fix  is planned for 601 patch1 and not 601 fcs).

Because it is marked as release601_fixes_candidate, this bugfix will be included in the upcoming patch for 6.0.1 (and
will be verified by QE in 6.0.1 at that time).

Comment 8 Karthikeyan Rajeswaran 2008-01-14 21:28:30 UTC
Changed status whiteboard value to release601_fixes_candidate1
Comment 9 Karthikeyan Rajeswaran 2008-02-11 05:58:11 UTC

Checking in src/org/netbeans/modules/visualweb/dataconnectivity/customizers/RowSetSelection.form;
The fix has been ported into the release601_fixes branch. 

/cvs/visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/customizers/Attic/RowSetSelection.form,v
 <--  RowSetSelection.form
new revision: 1.1.36.1; previous revision: 1.1
done
Checking in src/org/netbeans/modules/visualweb/dataconnectivity/customizers/RowSetSelection.java;
/cvs/visualweb/dataconnectivity/src/org/netbeans/modules/visualweb/dataconnectivity/customizers/Attic/RowSetSelection.java,v
 <--  RowSetSelection.java
new revision: 1.2.8.1; previous revision: 1.2
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo