Bug 93958 - Classpath to J2ME Ant extension library
Classpath to J2ME Ant extension library
Status: RESOLVED WORKSFORME
Product: javame
Classification: Unclassified
Component: Build System
5.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@mobility
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-02 09:02 UTC by blilleby
Modified: 2007-08-30 12:59 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
corrupted build.properties (1.76 KB, text/xml)
2007-04-25 16:44 UTC, Lukas Hasik
Details
messages.log (108.67 KB, text/plain)
2007-04-25 16:48 UTC, Lukas Hasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description blilleby 2007-02-02 09:02:10 UTC
I am using NetBeans IDE 5.5 with the Mobility Pack 5.5. Everything have been
working perfectly for months, but today suddenly I get this error when building
my J2ME program:

C:\Projects\SpaceMath\nbproject\build-impl.xml:55: Classpath to J2ME Ant
extension library (libs.j2me_ant_ext.classpath property) is not set. For
example: location of mobility/modules/org-netbeans-modules-kjava-antext.jar file
in the IDE installation directory.
BUILD FAILED (total time: 0 seconds)

The extension library is set in the Library Manager.

At the same time as this issue, I got a reference problem in a Java SE project:

Problem: The project uses a class library called "junit", but this class library
was not found.
Solution: Click Resolve to open the Library Manager and create a new class
library called "junit".

JUnit is indeed in the Library Manager.
Comment 1 Lukas Hasik 2007-02-05 11:20:44 UTC
Did it happen with new j2me project? Or with a project thet you copied (checkout). 
Did you changed your userdir location? Did you updated from 5.0 -> 5.5? 
What you did before it happen? E.g. add new modules, changed SDK/JDK, etc...

thanks for report
Comment 2 alanbur 2007-04-13 17:18:56 UTC
I too see the same thing - I'd installed the official 5.5 mobility pack after
uninstalling the beta version, and this started happening.  If someone could
look at a working install and find where this property is set, it would be a
great help towards figuring out what the cause of the problem is.
Comment 3 Lukas Hasik 2007-04-25 15:41:49 UTC
it happened to me today. I added a configuration, removed some optional packages
+ abilities, compile -> I received the "Classpath to J2ME Ant
extension library (libs.j2me_ant_ext.classpath property) is not set." 
I showed it to David, the conclusion is that whole build.properties are
corrupted. It was only one new project created in the IDE. 

I still do have the setup on my machine.
Comment 4 Martin Ryzl 2007-04-25 15:59:13 UTC
what version - 5.5, 5.5.1, 6.0?
I'm increasing priority.
Comment 5 Adam Sotona 2007-04-25 16:05:44 UTC
Please attach the log and the corrupted build.properties.
There has to be some hint who corrupted the file and why.
Comment 6 Adam Sotona 2007-04-25 16:07:34 UTC
issuezilla is very funny

I did not intend to change the priority back to P3 but the Issuezilla did it for
me :)
Comment 7 Lukas Hasik 2007-04-25 16:28:09 UTC
551, build from 0423
Comment 8 Lukas Hasik 2007-04-25 16:44:18 UTC
Created attachment 41646 [details]
corrupted build.properties
Comment 9 Lukas Hasik 2007-04-25 16:48:42 UTC
Created attachment 41647 [details]
messages.log
Comment 10 Adam Sotona 2007-04-25 16:54:24 UTC
no exception in log and just all libraries missing in build.properties -
reassigning to project/libraries
Comment 11 Tomas Zezula 2007-08-16 08:03:52 UTC
Someone corrupts the build.properties. I doubt the library manager is responsible for it, seems rather as j2me problem.
Noone is able to reproduce it when there is no j2me modules installed and according to lhasik the build.propertis
corrupts when he switches the configuration. Needs to find who corrupts the file, dtrace (Solaris) or filemonitor
(Windows) can help with this.
Comment 12 Tomas Zezula 2007-08-30 12:53:35 UTC
Seems as 
Comment 13 Tomas Zezula 2007-08-30 12:59:22 UTC
Some module rewrites the build.properties, it happens only when the mobility modules are installed and it's a
consequence of configuration + optional pkgs manipulation => probably mobility issue.
Anyway I was not able to reproduce it in NB 6.0, seems fixed.
Lukas can you verify it?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo