Bug 93881 - I18N - RFE - provide or add to i18n tutorials for doing i18n in multipage applications
I18N - RFE - provide or add to i18n tutorials for doing i18n in multipage app...
Status: RESOLVED INVALID
Product: obsolete
Classification: Unclassified
Component: visualweb
5.x
Sun Solaris
: P2 (vote)
: TBD
Assigned To: Gail Chappell
issues@obsolete
: I18N
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-02-01 22:04 UTC by bugbridge
Modified: 2011-11-28 17:29 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugbridge 2007-02-01 22:04:48 UTC
Description:
from customer feedback and  based on discussions with Alexander
(or from other analysis and discussions of issues and features where we thought
an rfe for i18n could be helpful)

if this is duplicate of existing rfe related to i18n, please close
as duplicate; we have looked at existing rfes with words i18n in synopsis and
tried not to file any duplicates. 

customer feedback:

1. summary from Craig related to customer issues:

a demonstration of
how to do i18n in a multi-page application. the demo-application
in the tutorial is only a single-page application. for me, the
single-page stuff works, but multi-page seems to require something i
n addition.  Single-page meaning: one page where the language / locale
 can be selected by the user, one or more other pages where the
selected locale setting is visibly applied. 

(due to architecture of jsf, on which related rfe is being filed, some of the
steps needed to accomplish the multipage app as to i18n might be viewed as
workarounds, and a related functional rfe is being filed to see if those 
steps can be provided easier for the customer)


2. customer feedback from a long email thread with Craig's suggestions
is attached; for more specfic information on exactly what would be helpful
for tutorial, Craig can provide that.

Description (Entry 2):
additional feedback and comments from internal customer

 separate the page where the language can be changed from the pages
which would be affected by the language change. this is a much more
realistic, real-world scenario than the single-page example, and it
seems to be more difficult to get it working. Note: demonstrate both
"standard" navigation and URL / redirect navigation (because there seems
to be another pitfall related to this difference).

Evaluation:
This is a good suggestion and we will add this information to the tutorial when
we update the tutorial for Mako.
Comment 1 Jiri Prox 2007-09-17 21:39:17 UTC
Obsolete milestone, please reevaluate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo