Bug 9323 - Customizer of FS don't work
Customizer of FS don't work
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Linux
: P2 (vote)
: TBD
Assigned To: Jesse Glick
issues@platform
:
: 9035 (view as bug list)
Depends on:
Blocks: 11446
  Show dependency treegraph
 
Reported: 2001-01-31 16:56 UTC by dmladek
Modified: 2008-12-22 17:49 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Suggest patch (note: MountNode patch simpler, probably independent of openide patch) (12.98 KB, patch)
2001-10-03 10:06 UTC, Jesse Glick
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description dmladek 2001-01-31 16:56:25 UTC
[Pilsen-010131CE]
jdk1.3.1beta b14 sun
rh 7.0
====================

I've already fired a bug #9035 agains Customizer dialog of FS
(changing order).

But now, I've found another:
If I select a FS(any type) and from its popup menu
I choose Unmount FS, nothing happen:-(
Comment 1 dmladek 2001-01-31 16:57:59 UTC
is it core or openide? Probably core:-/
Comment 2 Jesse Glick 2001-01-31 18:02:59 UTC
Definitely core, and please remember to click "Reassign bug to owner of selected
component" when changing categories.
Comment 3 Jaroslav Tulach 2001-02-05 13:36:59 UTC
Ales, I have never seen such bug, so if you do not reproduce it quickly, just
close it.
Comment 4 Jaroslav Tulach 2001-02-05 14:48:59 UTC
*** Bug 9241 has been marked as a duplicate of this bug. ***
Comment 5 akemr 2001-02-05 15:34:59 UTC
I cannot reproduce this bug, so I marked it WORKSFORME. If there will be
reproducing steps, please reopen this bug report.
Comment 6 dmladek 2001-02-05 15:49:59 UTC
On which platform you haven't been able to reproduce it?
Customizer Dialog of FSs doesn't work at all! On linux and W2K.

Steps to reproduce:
===================
*Have at least one FS mounted in your IDE !!!
*Right click on the root of all nodes (Filesystems) in the Explorer window
*Select Customize from popup menu
*Right click on any offered FS in right part of JUST popuped Customizer Dialog
**Select Unmount Filesystem from popup menu
--- > This doesn't work
**Select move up/down
--- > This doesn't work too
**Customize
--- > This doesn't work too
**Properties
--- > This doesn't work too
===============================================
Comment 7 Jaroslav Tulach 2001-02-05 16:00:59 UTC
Hi Jano, this bug is likely caused by your improvements in WizardDescription (or
NbPresenter) I do not know for sure. But you said that your are now
encapsulating the component in DialogDescriptor by another one!? If so, the
component should implement ExplorerManager.Provider and delegate the original
component (if it implements the interface too) or just return null otherwise.

I rised the priority because this can influence everyone.
Comment 8 jrojcek 2001-02-08 07:53:59 UTC
Well, I made changes to WizardDescriptor (not DialogDescriptor or NbPresenter)
and I think that it didn't cause this bug. I reassign bug back to core.
Correct me if I am wrong.
Comment 9 Jaroslav Tulach 2001-02-08 10:42:59 UTC
Another trouble with ModuleActions.invokeAction (). The CustomizerAction blocks
the request processor, so no other actions (from the customizer) can be invoked.

Jesse, can you try if it helps to make CustomizeAction run in AWT-thread (the
needAWT property in the action or what we have discussed).
Comment 10 Jesse Glick 2001-02-08 11:33:59 UTC
OK, that might do it...
Comment 11 Jesse Glick 2001-02-13 11:36:59 UTC
*** Bug 9188 has been marked as a duplicate of this bug. ***
Comment 12 dmladek 2001-02-13 13:51:59 UTC
MArket as verified.

But at the first attempt to do some action in FS customizer,
an Exception was thrown to my console:-(
It appered only once time and after it the FS customizer worked properly.

java.lang.IllegalStateException
	at
org.openide.util.RequestProcessor$ProcessorThread.synch(RequestProcessor.java:484)
	at
org.openide.util.RequestProcessor$ProcessorThread.run(RequestProcessor.java:499)
Comment 13 Marian Mirilovic 2001-02-23 15:32:11 UTC
[jdk 1.3.1(b17)] [pilsen](010222) solari 8

In Options , if you want change order of Categories in component palette by
selection popup menu Move Up/Down (or by window Change order), it doesn't work.

Comment 14 Jesse Glick 2001-02-23 15:39:43 UTC
It works for me (ant -Dmodules=java,clazz,form,projects trybuild), and anyway it
would probably be a form bug if it worked for other things.
Comment 15 dmladek 2001-02-26 10:24:40 UTC
*** Issue 9035 has been marked as a duplicate of this issue. ***
Comment 16 dmladek 2001-02-26 10:30:08 UTC
Verified as functional on [Build-010222_1IE]
Comment 17 dmladek 2001-10-02 09:01:37 UTC
REGRESION: so this must be marked as P1, sorry
   'cause ORDERING FS, and issue #14793 (ordering FS is  spontanious)... so there is no workaround how to arrange your CLASSPATH
=====================================================================
Customizer dialog doesn't provide any extra functionality as it used to provide:
 * I can't change order of FS....this is really P1
   (used to be issue #9035, but this issue has been marked
   as a duplicate of this one)
 * I can't unmount FS
because those action have disapeared from the popup menu.


and if you select the TOP node "Filesystems Settings" and from popup menu choose "Change order..." the dialog where you could arrange FS's order is disabled...I mean you could only close it by "X" button in the right top corner....

(Probably Customizer dialog is MODAL? I don't understand this dialog well, 'cause if you inwoke mounting Wizard you could mount it...)

Comment 18 Jesse Glick 2001-10-03 10:04:01 UTC
Yarda/David/etc. please read--

I can fix this, but only with an API change. Opening a raw JDialog for
the customizer causes the problems. If you use a dialog descriptor it
is OK. I will attach a suggested patch; adding one public static
method. I am not sure if it is the best place for it; I would like to
deprecate IndexedCustomizer as an accessible class because it seems
ugly to me, but I want someone to review this and give a second
opinion. The attached patch does seem to correct the problem. Also it
provides a working Cancel button on the reorder dialog (OK applies
changes, otherwise they are not applied); and half of #11446 is also
fixed--JavaHelp works correctly with the reorder dialog.

Of course if we just made our dialogs nonmodal we would not have such
problems, but this is a UI change with broader impact, too late for
3.3 I guess.

So someone please look at the patch and let me know if this sounds
like a reasonable API change, or if you can think of a fix that does
not involve any API change.
Comment 19 Jesse Glick 2001-10-03 10:06:09 UTC
Created attachment 2818 [details]
Suggest patch (note: MountNode patch simpler, probably independent of openide patch)
Comment 20 Jaroslav Tulach 2001-10-04 07:52:49 UTC
At the begining I was not sure, but it seems that the code will still
run as standalone. That is ok.

I have seen a possible trouble in IndexNode.getCustomizer!? Because it
will still suffer from the same problem?

If so, should not we have a method 

Dialog Index.Support.createReorderDialog (Index index) 

or something like that?

Deprecating IndexedCustomizer is ok, the class should never be there.

Last comment: Why create new interface ICShower - better move the code
to TMUtil and reuse the infrastructure there.


Comment 21 Jesse Glick 2001-10-05 12:11:11 UTC
IndexedNode.getCustomizer should with the patch be creating a plain
JPanel which would then be wrapped in a normal customizer dialog, so I
think this is OK. I noticed it was adding the Close button, this is
probably wrong. However I did not really test this class, I should.

Yes TMUtil would be a better place for the shower interface. I was too
lazy, but I can do that.
Comment 22 Jesse Glick 2001-10-11 23:20:19 UTC
Fixed. IndexedNode seems OK (though in fact no one in nb_all is using
its customizer); TMUtil used to encapsulate TopManager stuff.

1.31  openide/openide-spec-vers.properties
1.24  openide/api/doc/changes/apichanges.xml
1.116 openide/src/org/openide/loaders/DataFolder.java
1.21  openide/src/org/openide/nodes/Index.java
1.27  openide/src/org/openide/nodes/IndexedCustomizer.java
1.8   openide/src/org/openide/nodes/IndexedNode.java
1.3   openide/src/org/openide/nodes/TMUtil.java
Comment 23 Jan Zajicek 2001-10-23 07:46:41 UTC
dev #20011019
Comment 24 Quality Engineering 2003-07-01 16:14:53 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo