Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 93131 - Dynamically attach helpsets to running IDE
Dynamically attach helpsets to running IDE
Status: CLOSED DUPLICATE of bug 93134
Product: platform
Classification: Unclassified
Component: Help System
5.x
All All
: P2 (vote)
: 6.x
Assigned To: mslama
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-24 19:09 UTC by _ edwingo
Modified: 2008-12-22 11:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ edwingo 2007-01-24 19:09:40 UTC
The use case is component libraries in Visual Web Pack (VWP), though this
feature would also be useful to the IDE in general. VWP has a special "complib"
component library file that a user can import versioned third-party components
into the IDE. The complib file has a set of components and contains one or more
JavaHelp HelpSets for the components. During the import process the HelpSet-s
should be installed and merged into the IDEs help system. Currently, the only
way I know of installing a HelpSet is through static layer files in a Library
Wrapper Module. I have tried to use the NetBeans FileSystem APIs to do the
equivalent but have not figured out how to. Here is an email on the subject:

I would like to programmatically add JavaHelp sets to NetBeans
dynamically without using NBMs and restarting the IDE. Is this possible?
What is the best way to do this?

Ideally, I would like an easy way to accomplish this task without going through
the hassles of creating different layer files in the NetBeans filesystem. I've
mentioned this to some NetBeans developers who claim that it is possible with
the current code, but I would like answers to the following details so I can
implement it. Or better yet, I would like an easier way to accomplish the same task.

If I were to guess, I would create something in the system filesystem,
but I don't understand the details and what URLs to use.

  1. Create an XML file somewhere containing: <helpsetref
     url="nbdocs:/com/example/docs/my-helpset.hs"/>. Where?
  2. Create a new XML file in "Services/JavaHelp" that points to #1.
     What URL do I use?
  3. Add my helpset jars so NetBeans can find it using the nbdocs
     scheme. How can I do this and refer to it using the nbdocs scheme?


To see the use case, in VWP (see
http://blogs.sun.com/edwingo/entry/installing_netbeans_5_5_visual for installing
VWP), create a new "Visual Web Application" and navigate to Page1.jsp. Import a
component library by: Tools->Component Library Manager->Import and browse
a complib file. See
http://blogs.sun.com/edwingo/entry/unofficial_complib_with_prototype_popup for a
link to a complib file. After importing the complib file,
you must add the component library to your project. Goto the Projects Window and
invoke the context menu on the "Component Libraries" node to add an imported
component library to your project. Then the components should appear in the
palette when the view is set to "design" on Page1.jsp.
Comment 1 _ edwingo 2007-01-24 19:16:18 UTC

*** This issue has been marked as a duplicate of 93134 ***
Comment 2 Marian Mirilovic 2007-01-24 22:54:52 UTC
v/c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo