Bug 92919 - Profile Project doesn't work for GlassFish-targeted projects
Profile Project doesn't work for GlassFish-targeted projects
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Jiri Sedlacek
issues@profiler
it070320 it070403 it070417 javaone07
: REGRESSION, SPACE_IN_PATH
: 77638 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-21 13:19 UTC by Alexander Kouznetsov
Modified: 2007-04-27 16:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Configuration file after Profile Project action (22.87 KB, text/xml)
2007-01-21 13:21 UTC, Alexander Kouznetsov
Details
Server log (546.90 KB, text/plain)
2007-01-21 13:22 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2007-01-21 13:19:40 UTC
Profiler 070119
NetBeans IDE Dev (Build 200701141900)
1.5.0_10; Java HotSpot(TM) Client VM 1.5.0_10-b03
Windows XP version 5.1 running on x86
ru_RU (nb); Cp1251
Sun Java System Application Server Enterprise Edition 9.1 (build b28)

Steps to reproduce:
- Try to Profiler Enterprise Application targeting GlassFish
- RESULT: Server fails to start due to incorrect jvm-arguments. See attached log
and domain.xml files. After removing quotes from jvm-argument I was able to
start server in profiling mode manually and attach Profiler.

com.sun.enterprise.server.PELaunch
start
java.lang.NoClassDefFoundError:  -XX:+HeapDumpOnOutOfMemoryError
-XX:HeapDumpPath=C:\Work\Temp\NBProjects\OrderSystem\nbproject\private\profiler
 -agentpath:C:\Program Files\NetBeans 6/0
Dev\profiler1\lib\deployed\jdk15\windows\profilerinterface/dll="C:\Program
Files\NetBeans 6/0 Dev\profiler1\lib",5140
Exception in thread "main"
Comment 1 Alexander Kouznetsov 2007-01-21 13:21:32 UTC
Created attachment 37551 [details]
Configuration file after Profile Project action
Comment 2 Alexander Kouznetsov 2007-01-21 13:22:35 UTC
Created attachment 37552 [details]
Server log
Comment 3 Tomas Hurka 2007-02-14 16:49:27 UTC
*** Issue 77638 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Sedlacek 2007-02-15 12:26:41 UTC
Seems like a general space-in-path problem, isn't related just to GlassFish or 
profiling J2EE applications.

As a workaround until fixed NetBeans have to be installed on path without 
spaces.
Comment 5 Alexander Kouznetsov 2007-03-28 21:11:34 UTC
There is an easy fix for Windows - to remove quotes from path like this:
-agentpath:C:\Program Files\NetBeans 6/0
Dev\profiler1\lib\deployed\jdk15\windows\profilerinterface/dll=C:\Program
Files\NetBeans 6/0 Dev\profiler1\lib,5140

This is really annoying issue. Would you like to recommend user to reinstall IDE
from its default path if this feature is required?

I believe the priority could be raised since this is the main button "Profile
Project" which doesn't work for GlassFish on the main platform.
Comment 6 Alexander Kouznetsov 2007-04-17 14:14:56 UTC
REGRESSION since Profiler 5.5.1
Comment 7 Jiri Sedlacek 2007-04-23 15:59:15 UTC
Note that just removing the quotes isn't a fix, it's just a workaround which 
luckily works - or do you really think that "NetBeans 6/0 Dev" looks like 
correct path for "NetBeans 6.0 Dev"? The Profiler thinks that the argument is a 
classname, not agent binaries folder (translating 6.0 to 6/0).
Comment 8 Alexander Kouznetsov 2007-04-23 16:13:25 UTC
Why not? I would like to mention also "profilerinterface/dll" in this argument.
Comment 9 Jiri Sedlacek 2007-04-23 16:30:28 UTC
... which is also incorrect - in fact the whole contents in quotes is 
interpreted incorrectly.

The problem is caused by an OutOfMemory detection mechanism implemented in 6.0. 
As a workaround, disable it by selecting Do nothing in On OutOfMemoryError: 
section of Profiler Options.

Note that this bug will be fixed on a more general level covering all 
SPACE_IN_PATH related problems.

Lowering priority - simple workaround exists.
Comment 10 Ivan Sidorkin 2007-04-24 10:50:24 UTC
Moreover the profiled project should be created on path without spaces.
Comment 11 Jiri Sedlacek 2007-04-24 10:55:58 UTC
In fact space in project's path shouldn't be a problem. SPACE_IN_PATH problems 
are caused by space in profiler1 cluster's path.
Comment 12 Ivan Sidorkin 2007-04-24 12:34:48 UTC
Space in project's path definitely shouldn't be a problem as well as space in NB
path. But it is.
I created two projects. One with spase in path, other without.
I can profile application that doesn't have space in path and can't another one.
Comment 13 Jiri Sedlacek 2007-04-24 12:38:52 UTC
If so then please file a separate issue, this doesn't seem to be related to 
this problem - at least it's most likely not caused by the OOME detection 
mechanism.
Comment 14 Jiri Sedlacek 2007-04-24 16:25:20 UTC
Fixed for M9.
Comment 15 Alexander Kouznetsov 2007-04-27 09:50:36 UTC
Verification is blocked by issue 102467
Comment 16 Alexander Kouznetsov 2007-04-27 16:31:55 UTC
Verified with 
Profiler 070426
NetBeans IDE 6.0 Preview (M9, build 070427)
1.6.0; Java HotSpot(TM) Client VM 1.6.0-b105
Windows XP version 5.1 running on x86
ru_RU (nb); Cp1251

There is also another similar issue 102323 which is not fixed yet. Disabled OOME
mechanism to verify the issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo