Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 92904 - Move static methods to another class
Move static methods to another class
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Refactoring
5.x
All All
: P3 with 1 vote (vote)
: 7.2
Assigned To: Ralph Ruijs
issues@java
:
: 156499 (view as bug list)
Depends on:
Blocks: 204440 91516
  Show dependency treegraph
 
Reported: 2007-01-20 18:58 UTC by ptoye
Modified: 2012-02-08 15:01 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ptoye 2007-01-20 18:58:52 UTC
Can we please have a mechanism to move static methods to another class? All too
frequently I find that a "utility" class which is there simply to contain a
number of useful static methods gets too big, and needs to be split up into
separate files. The ability to use a refactor mechanism, rather than going
through the project editing each occurrence of the moved methods would save a
load of time.
Comment 1 Jan Pokorsky 2009-12-02 08:30:59 UTC
*** Bug 156499 has been marked as a duplicate of this bug. ***
Comment 2 Ralph Ruijs 2012-02-08 15:01:59 UTC
Fixed by http://hg.netbeans.org/jet-main/rev/7366a9a6ccf3


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo