Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 92291 - Palette is empty
Palette is empty
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Visual Designer
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Anton Chechel
issues@mobility
:
Depends on:
Blocks: 94640
  Show dependency treegraph
 
Reported: 2007-01-11 11:05 UTC by Lukas Hasik
Modified: 2007-02-20 13:01 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
happend again today (5.78 KB, image/png)
2007-02-06 15:33 UTC, Lukas Hasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2007-01-11 11:05:22 UTC
nb070110+mp070111

-when I created new visual midlet then it opened but some of the categories in
the palette were empty - e.g. Displayables, Commands

-restart of IDE fixed it
Comment 1 Anton Chechel 2007-01-16 10:21:39 UTC
Can't reproduce now. But if palette manager was not able to create some files in
the userdir then it was something very weird.
Comment 2 Lukas Hasik 2007-02-06 15:33:35 UTC
Created attachment 38114 [details]
happend again today
Comment 3 Lukas Hasik 2007-02-06 15:37:55 UTC
still don't have a reproducible scenario but it happens...
Comment 4 Lukas Hasik 2007-02-15 14:18:20 UTC
still happens in 070215 build
Comment 5 Lukas Hasik 2007-02-16 10:52:23 UTC
in latest builds 070215 and070216 the bug appears almost everytime. It's really
annoying and blocks users from using the visual designer. 
It happens for both designers (old+new) therefore it's probably palette problem.

There is easy workaround - right click to empty palette and choose e.g. Sort by
Item Name/Category or Create New Category. It will cause palette refresh and the
items appear.

It is stopper for Milestone 7. See the reasons in first paragraph
Comment 6 Lukas Hasik 2007-02-16 10:58:06 UTC
the palette appears completely empty - looks like only empty pane in inside 
Comment 7 Anton Chechel 2007-02-16 14:05:07 UTC
Working on it.
Comment 8 Anton Chechel 2007-02-20 12:53:09 UTC
was bug in Palette API, fixed
Comment 9 Lukas Hasik 2007-02-20 13:01:20 UTC
verified in 070220_1 (M7)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo