Bug 92204 - I18N - netbeans application menu is not localized
I18N - netbeans application menu is not localized
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
5.x
Macintosh Mac OS X
: P2 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
: I18N
: 99749 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-10 12:22 UTC by Jan Lana
Modified: 2008-12-22 11:00 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
netbeans application menu (78.33 KB, image/png)
2007-01-10 14:00 UTC, Jan Lana
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Lana 2007-01-10 12:22:20 UTC
Content of 'NetBeans' application menu is not localized. see attached screenshot.

Tested locales: ja, pt_BR
Comment 1 Marian Mirilovic 2007-01-10 12:55:59 UTC
Where is an attachment ?
Comment 2 Jan Lana 2007-01-10 14:00:53 UTC
Created attachment 37222 [details]
netbeans application menu
Comment 3 Jan Lana 2007-01-10 14:08:57 UTC
sorry. the attachment is created
Comment 4 Ken Frank 2007-03-22 19:28:03 UTC
Are the words for that menu items in a bundle fille in a product jar ?

In the /org-netbeans-modules-applemenu
the only bundle file has none of these kinds of labels.

seems they would need to be in a bundle file,

am moving this to p2 since if its true, it means users of localized bits
would not be able to see these messages in their language 
and to them its a serious situation
(image if we saw in english what should be the menu item "File"
as "ZZZZ" - I think it would be serious to english user.

ken.frank@sun.com

ken.frank@sun.com
Comment 5 David Simonek 2007-03-28 13:39:29 UTC
Milos, please look at this for me, thanks. Probably some bundles will have to be
added into applemenu module.
Comment 6 Milos Kleint 2007-03-28 13:47:04 UTC
not really sure this is something we can influence.
do you have your macosx in portuguese completely or you running only the
netbeans app in portuguese (sorry, if I didn't recognize the language correctly)

all we do in applemenu is to map a specific netbeans window to "Preferences.."
and "About" and make sure the "Quit" item gets channeld through our application.
All these labels are handled by either apple's java or the OS I suppose.
Comment 7 novakm 2007-04-10 12:43:04 UTC
*** Issue 99749 has been marked as a duplicate of this issue. ***
Comment 8 Jan Lana 2007-04-16 08:36:25 UTC
Yes, I have the macos in pt_BR. Other applications have the menu localized.
Comment 9 Milos Kleint 2007-04-16 11:15:37 UTC
my current evaluation is that this has to do with java apps on macosx in general.

1. i've checked the applemenu module and we are not constructing the Netbeans
menu item and it's content. we're just plugging actions/listeners into the
apple's java apis.
2. I've run my mac with chinese locale. The only apps that were localized were
the ones coming from apple with the OS. I installed IntelliJ and Eclipse. While
IntelliJ was having the menu in english, Eclipse did have it in chinese though.
Eclipse is not distributed as a Eclipse.app bundle though.
3. I've created a sample java bundle in Xcode and that one had the menu also in
english. Their Info.plist file with bundle information was similar to ours.
Comment 10 Milos Kleint 2007-04-17 15:01:40 UTC
when trying out with german or japanese local my test application started to
have the menu localized correctly.

I figured (with help of thurka) that the bundles for the menu are localized in the 
/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Resources folder. On
my machine there are only localizations for german, french, english and
japanese. Any other localization will not work in this menu.
If I set my preferred language of choice german and start netbeans, the
left-most menu is correctly appearing in german for me.

closing as wontfix as it's something we cannot influence.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo