Bug 91815 - redesign Search History
redesign Search History
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
All All
: P1 with 4 votes (vote)
: 7.2
Assigned To: issues@versioncontrol
issues@versioncontrol
: PLAN
: 78059 81324 84346 91178 110699 151630 169878 197749 (view as bug list)
Depends on: 165941 156599
Blocks: 78885
  Show dependency treegraph
 
Reported: 2007-01-04 13:42 UTC by Tomas Stupka
Modified: 2012-01-02 09:08 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Stupka 2007-01-04 13:42:02 UTC
the search history functionality is not intuitive and hard to use
Comment 1 Tomas Stupka 2007-01-04 13:43:41 UTC
btw - this is an umbrella
Comment 2 Tomas Stupka 2007-01-04 13:45:36 UTC
sorry, i just changed my mind - this is not an umbrella :)
Comment 3 Tomas Stupka 2007-01-04 13:46:00 UTC
*** Issue 84346 has been marked as a duplicate of this issue. ***
Comment 4 Tomas Stupka 2007-01-04 15:48:40 UTC
*** Issue 90311 has been marked as a duplicate of this issue. ***
Comment 5 Tomas Stupka 2007-01-04 15:48:57 UTC
*** Issue 78059 has been marked as a duplicate of this issue. ***
Comment 6 Tomas Stupka 2007-01-04 15:49:11 UTC
*** Issue 81324 has been marked as a duplicate of this issue. ***
Comment 7 Tomas Stupka 2007-01-04 15:50:58 UTC
*** Issue 84346 has been marked as a duplicate of this issue. ***
Comment 8 Tomas Stupka 2007-01-04 15:52:03 UTC
*** Issue 91178 has been marked as a duplicate of this issue. ***
Comment 9 Tomas Stupka 2007-02-06 13:05:48 UTC
problem with search history reported in issue #88304


When I click on "Versioning | Search "Test.java" History" I expect that one way
or another I'll be able to browse through the history of changes for "Test.java". 

> Expanding the revision numbers you can select two desired "Test.java" file in 
> particular revision.

It doesn't work. Suppose that revision 3 has committed 4 files. So, I see
something like the following in the "Summary" tab:

3 luser <some date here>
<Comment message for revision 3 commit>                 [Diff] [Revert]
A.java
B.java
C.txt
Test.java

2 luser <some date here>
<Comment message for revision 2 commit>                 [Diff] [Revert]
D.java
Test.java
Z.java

Selecting "Test.java" from the list above and then clicking on the respective
[Diff] will not get me the diff between 2 revisions of "Test.java". Instead, NB
appears to always show the diff for the first file in the list, in this case,
that will be "A.java". Clicking on the [Diff]  for revision 2 will get you the
diff for "D.java".

The "Diff" tab has the same problem as the "Summary" tab.

Note: I should not even have to select/click on Test.java, for I already
requested The history for "Test.java" to begin with.
Comment 10 Tomas Stupka 2007-02-06 13:54:33 UTC
fixed the problem from the previous post

Checking in DiffResultsView.java;
/cvs/subversion/main/src/org/netbeans/modules/subversion/ui/history/DiffResultsView.java,v
 <--  DiffResultsView.java
new revision: 1.9; previous revision: 1.8
done
Comment 11 oneway 2007-02-24 03:07:31 UTC
"Search History" works well, very pleased, thanks. One small change I'd
recommend is to make the "Diff" tab the default/first one, instead of the "Summary".

When I search history I generally want to see the history of *changes* made to a
particular file, not the list of files in the affected commits.
Comment 12 pribyl 2008-02-22 09:35:39 UTC
Voted for this issue.
Would be great if "Search history" can be turned to more intuitive instrument.

For example if user could choose whether he wants to use Case sensitive, Whole words search etc. 

Thx.
Comment 13 muligan 2008-10-17 20:00:55 UTC
The summary pane could use a "copy to clipboard" feature by entry or selected entries. 

Button, menu item, or keyboard shortcut would be equally fine for me. I often create "change log" sets by starting with
the commit logs and rehashing them into "What's new" information and having to retype 5 pages of entries gets a bit tedious.
Comment 14 Tomas Stupka 2008-10-29 11:28:38 UTC
*** Issue 151630 has been marked as a duplicate of this issue. ***
Comment 15 Tomas Stupka 2008-12-10 07:18:29 UTC
> The summary pane could use a "copy to clipboard" feature by entry or selected entries. 
this should work - just select some list entries and use the copy shortcut - e.g ctrl-c on windows
Comment 16 Tomas Pavek 2009-10-08 17:09:59 UTC
Would also be very useful to allow to collapse the section with files for displayed commits, and also show the files
collapsed initially if there are more than certain number of files. E.g. in NetBeans repository there are commits over
all repository (e.g. license upgrades) that make the history view unusable - showing thousands of files for some commits
make the other short commits almost undiscoverable.

In addition, it would be nice to first show and highlight the files that are relevant in the context the history
searched was invoked on. So e.g. when viewing a commit over multiple projects I can see the files of the project I'm
interested in first.
Comment 17 Tomas Stupka 2009-11-02 12:49:06 UTC
*** Issue 110699 has been marked as a duplicate of this issue. ***
Comment 18 Ondrej Vrabec 2011-06-09 13:03:51 UTC
*** Bug 169878 has been marked as a duplicate of this bug. ***
Comment 19 Ondrej Vrabec 2011-06-09 13:05:37 UTC
*** Bug 197749 has been marked as a duplicate of this bug. ***
Comment 20 Quality Engineering 2011-12-24 15:57:53 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/df356619c45e
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #91815 - redesign Search History
shared summary view
Comment 21 Quality Engineering 2011-12-31 15:43:21 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/68d72f9b3e37
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #91815 - redesign Search History
implementation in git
Comment 22 Quality Engineering 2012-01-01 15:57:39 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/25448614271f
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #91815 - redesign Search History
implementation in subversion
Comment 23 Ondrej Vrabec 2012-01-02 09:08:43 UTC
fixed in mercurial: #95d185c27a3a, git: #68d72f9b3e37 and subversion: #25448614271f
marking the issue as fixed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo