Bug 91450 - WSDL validation should check for binding operation signature to be same as portType operation signature.
WSDL validation should check for binding operation signature to be same as po...
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: WSDL Model
5.x
All All
: P1 (vote)
: TBD
Assigned To: Roderico Cruz
issues@xml
:
Depends on:
Blocks: 89313
  Show dependency treegraph
 
Reported: 2006-12-22 01:18 UTC by Ritesh Adval
Modified: 2007-02-21 19:22 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
diff of changes to WSDLSemanticsVisitor (4.64 KB, text/plain)
2007-01-04 00:05 UTC, Roderico Cruz
Details
Second diff that added validation of binding input/output names (2.86 KB, text/plain)
2007-01-04 22:30 UTC, Roderico Cruz
Details
Yet another diff: flag input/output/fault mismatches as errors and name mismatches as warnings (6.00 KB, text/plain)
2007-01-05 00:33 UTC, Roderico Cruz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ritesh Adval 2006-12-22 01:18:18 UTC
WSDL validation should check for binding operation signature to be same as 
portType operation signature.

Ex:


is an example:
 
    <wsdl:portType name="FTPPortType">
        <wsdl:operation name="FTPOperation">
            <wsdl:input name="input1" message="tns:FTPOperationRequest"/>
            <wsdl:output name="output1" message="tns:FTPOperationReply"/>
        </wsdl:operation>
    </wsdl:portType>
    <wsdl:binding name="binding1" type="tns:FTPPortType">
        <ftp:binding/>
        <wsdl:operation name="FTPOperation">
            <ftp:operation/>
            <wsdl:input name="input1">
                <ftp:messageActivePassive messageRepository="Provide value for 
this required attribute" use="literal"/>
            </wsdl:input>
        </wsdl:operation>
    </wsdl:binding>

abstract operation : FTPPortType->FTPOperation requires <wsdl:input> and 
<wsdl:output>
binding operation : binding1->FTPOperation binds to operation only require 
<wsdl:input>
 
the 'signature' of the operation is not checked by validation
Comment 1 Ritesh Adval 2006-12-22 01:23:59 UTC
This should be fixed in Gavotte.

The change to be done in in wsdl validator.
see xml/wsdl/api/ 
org.netbeans.modules.xml.wsdl.validator.visitor.WSDLSemanticsVisitor

Fix in public void visit(Binding binding) { to add logic to validate binding 
operation signature to be same as portType operation.

Comment 2 Roderico Cruz 2007-01-03 23:46:03 UTC
Changed priority to P1 because this is needed for Gavotte.
Comment 3 Roderico Cruz 2007-01-03 23:50:26 UTC
Fixed in the trunk.
Comment 4 Roderico Cruz 2007-01-04 00:05:12 UTC
Created attachment 37025 [details]
diff of changes to WSDLSemanticsVisitor
Comment 5 Roderico Cruz 2007-01-04 22:28:13 UTC
Added validation of binding input/output names (if any) to match the names in
the portType. See diff.
Comment 6 Roderico Cruz 2007-01-04 22:30:27 UTC
Created attachment 37056 [details]
Second diff that added validation of binding input/output names
Comment 7 Roderico Cruz 2007-01-05 00:33:14 UTC
Created attachment 37059 [details]
Yet another diff: flag input/output/fault mismatches as errors and name mismatches as warnings
Comment 8 Ritesh Adval 2007-01-05 03:31:32 UTC
The changes seems fine.
Comment 9 Chris Webster 2007-01-05 04:44:03 UTC
Please add unit tests to reproduce / verify the fixes. 
Comment 10 jlautz 2007-02-21 19:22:55 UTC
Verified on Windows XP with GAvotte 070220_4 and JDK 1.5.0_10.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo