Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 91007 - Browse button disabled in Add Managed Bean dialog
Browse button disabled in Add Managed Bean dialog
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSF
6.x
All All
: P3 (vote)
: 6.x
Assigned To: martin_adamek
issues@javaee
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-13 09:57 UTC by Jiri Skrivanek
Modified: 2007-11-02 10:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2006-12-13 09:57:44 UTC
Browse button should be enabled in the Add Managed Bean dialog. To reproduce:

- create web application with JSF framework
- open 'Configuration Files|faces-config.xml' file
- call 'JavaServer Faces|Add Managed Bean' action in editor
- Browse button should be enabled in the 'Add Managed Bean' dialog

Build 20061212-2258, JDK1.5.0_10, WindowsXP.
Comment 1 Petr Pisl 2006-12-13 12:41:13 UTC
The Browse button is disabled due to the rewriting jsf module to retouche. There
is missing the implementation of th dialog. Similar in Struts module.
Comment 2 Jiri Skrivanek 2007-01-08 13:11:38 UTC
Adding dependence because it is targeted for milestone 6.
Comment 3 Jan Horvath 2007-01-10 09:04:38 UTC
Removing dependency because it was decided, this is not a stopper for M6
Comment 4 Petr Pisl 2007-06-28 17:32:21 UTC
We have to decide, whether we will have similar functionality or we will just delete the button.
Comment 5 Petr Pisl 2007-08-03 14:12:32 UTC
Decreasing priority. Easy workaround.

Martin Adamek is working on a dialog, which should be displayed after clicking on the Browse... button and the dialog
should provide all the functionality, which we need. When the dialog will be done, it will be trivial to fix this. 
Comment 6 Petr Jiricka 2007-10-30 12:37:58 UTC
Martin, could you please look at this one as well? Sounds like this should be easy to fix for you. Thanks.
Comment 7 martin_adamek 2007-11-01 17:36:12 UTC
Fixed in AddManagedBeanDialog, version 1.7
Comment 8 Jiri Skrivanek 2007-11-02 10:11:18 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo