Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 90833 - Unclean uninstallation of ML java tools bundle/enterprise pack
Unclean uninstallation of ML java tools bundle/enterprise pack
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: Code
5.x
All All
: P2 (vote)
: 5.x
Assigned To: dlipin
issues@installer
:
: 90832 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-08 17:02 UTC by mariadavydova
Modified: 2007-02-13 13:25 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mariadavydova 2006-12-08 17:02:16 UTC
Install Java EE 5 Tools Bundle or Netbeans Enterprise Pack 5.5.
Uninstall product.
See below list of not empty directories still present after uninstallation.
<INSTALL_PATH>\SUNWappserver\imq\lib\
<INSTALL_PATH>\SUNWappserver\lib\

Problem happens with netbeans-ent_pack-5_5-main-061207-ml and
java-tools-bundle-main-061207-ml bits.
Comment 1 Will Zhang 2006-12-11 04:01:32 UTC
When finished the ml coke/coke bundle Uninstall, one "note" will display on the 
window:
"Note: Some files could not be deleted from the installation directory. It is 
safe to remove them manually."

I suppose this issue could be ignored.
Installer team, could you clarify it?
Comment 2 Kirill Sorokin 2006-12-11 05:09:58 UTC
Well, the policy is to try to stay as "clean" as possible. Thus this is an issue
for engineering, which should be investigated, and if we cannot do anything
about it, it will be WONTFIX'ed.
Comment 3 dlipin 2006-12-11 09:34:34 UTC
Fixed both for EntPack and JavaToolsBundle.
Please verify on the next RC of ML build.
Comment 4 dlipin 2006-12-11 09:37:20 UTC
*** Issue 90832 has been marked as a duplicate of this issue. ***
Comment 5 Will Zhang 2006-12-13 08:28:56 UTC
Build RC2

Verified on S10 Sparc/Win2K
bundle uninstall: "netbeans-5.5" empty dir is left
coke unistall    : one jar file is left, Install_dir/AppServer/lib/ant/lib/jbi-
ant-tasks_l10n.jar
Verifed on MacOs
bundle uninstall: one jar file is left, Install_dir/AppServer/lib/ant/lib/jbi-
ant-tasks_l10n.jar
coke uninstall:   one jar file is left, Install_dir/AppServer/lib/ant/lib/jbi-
ant-tasks_l10n.jar
Comment 6 mariadavydova 2006-12-13 16:16:14 UTC
Verified with java-tools-bundle-main-061212_1-ml and
netbeans-ent_pack-5_5-main-061212_1-ml
Solaris x86, Linux
bundle uninstall: "netbeans-5.5" empty dir is left
ent. pack unistall: one jar file is left, Install_dir/AppServer/lib/ant/lib/jbi-
ant-tasks_l10n.jar
on MacOs
bundle uninstall: one jar file is left, Install_dir/AppServer/lib/ant/lib/jbi-
ant-tasks_l10n.jar
ent. pack uninstall:   one jar file is left, Install_dir/AppServer/lib/ant/lib/jbi-
ant-tasks_l10n.jar  
Comment 7 dlipin 2007-02-13 13:25:42 UTC
Fixed in 5.5.1 beta.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo