Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 90654 - Project from 5.5u1 using AGUI uses wrong execution method
Project from 5.5u1 using AGUI uses wrong execution method
Status: VERIFIED WONTFIX
Product: javame
Classification: Unclassified
Component: CDC pack
5.x
All All
: P3 (vote)
: 5.x
Assigned To: luky
issues@mobility
: RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-06 11:59 UTC by Lukas Hasik
Modified: 2007-07-12 09:12 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
project from CDC Pack 5.5u1 with AGUI profile (14.36 KB, application/x-compressed)
2006-12-06 15:15 UTC, Lukas Hasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2006-12-06 11:59:42 UTC
-have a CDC project from Mobility Pack for CDC 5.5 update1 that has CDC TK as
platform and profile s AGUI

-open the 'old' project in 5.r RC builds and upgrade it
-run will end with 

run:
java.lang.NoSuchMethodException: main
        at java.lang.Class.getMethod0(Native Method)
        at java.lang.Class.getMethod(Class.java:958)
        at sun.misc.CVM.runMain(CVM.java:460)
F:\netbeans\projectsCDC\5.5-fcs-testing\rc1\1206\modules\mobileedition\testing\projectsCDC\Cdc55up1-CDC_TK10_EA-AGUI\nbproject\build-target-impl.xml:130:
Emulator execution failed!
BUILD FAILED (total time: 2 seconds)

-this problem is caused by wrong execution method
Comment 1 Lukas Hasik 2006-12-06 12:07:50 UTC
imo, this is valid issue. Users will expect that the upgrade should solve issues
like this. I agree that it has easy workaround and this issue should be a corner
case. Anyway it's worth to notice it in release notes

RELNOTE: Please, set up Xlet execution method for upgraded projects using AGUI
that were created with Mobility Pack for CDC 5.5 update1
Comment 2 luky 2006-12-06 12:20:14 UTC
i Will have a look, if it is a easy fix I will try to implement it, but I am 
bit suspicious that won't be that easy
Comment 3 Lukas Hasik 2006-12-06 14:50:14 UTC
the problem is caused by Mobility Pack 5.5 Update1 build. The execution is set
to main althrough it creates xlet when creating project in 5.5u1.
Comment 4 Lukas Hasik 2006-12-06 15:15:39 UTC
Created attachment 36520 [details]
project from CDC Pack 5.5u1 with AGUI profile
Comment 5 luky 2006-12-07 11:27:50 UTC
Can't really fix it. Please mention it in release notes that to run the 
project you must set the correct execution type in properties/run dialog
Comment 6 Lukas Hasik 2007-07-12 09:12:18 UTC
setting up the target milestone.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo