Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 90292 - VisualWeb pack breaks D&D in SOA projects
VisualWeb pack breaks D&D in SOA projects
Status: VERIFIED FIXED
Product: obsolete
Classification: Unclassified
Component: visualweb
5.x
All All
: P2 (vote)
: TBD
Assigned To: _ sandipchitale
issues@obsolete
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 16:20 UTC by Alexander Pepin
Modified: 2007-01-26 20:36 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2006-11-29 16:20:01 UTC
It's an integration issue. The problem occurs when installed both VisualWeb and
Enterprise packs.
Steps to reproduce:
- install netbeans
- install enterprise pack
- install visualweb pack
- start IDE
- create Samples/SOA/Synchronous sample project
- create a new SOA/BPEL Module project
- add a new bpel process
- expand SynchronousSample/Process Files
- try to drag SynchronousSample.wsdl to the diagram to create a new partner link
Result: Drag&Drop function does not work for wsdl files.
Comment 1 _ sandipchitale 2006-12-08 20:41:39 UTC
Looks like the ClipboardConvertor installed by VWP does not check for VWP 
Project type. As a result the returned document root (web folder) is null. 
That is passed to FileUtil.isParentOf() API which throws the observed 
IllegalArgumentException.
Comment 2 astashkova 2006-12-19 09:59:10 UTC
Issue added to the following docs:
1. NetBeans Enterprise Pack 5.5 Release Notes at
http://www.netbeans.org/community/releases/55/entpack_relnotes.html#90292
2. Java EE 5 Tools Bundle Release Notes at
http://java.sun.com/javaee/sdk/tools/sdkentpack_relnotes.jsp#90292
Comment 3 _ alexpetrov 2007-01-10 16:21:05 UTC
This bug is verified on environment:
Product Version         = NetBeans IDE 5.5 (Build 200610171010)
Operating System        = Windows XP version 5.1 running on x86
Java; VM;               = 1.6.0-rc; Java HotSpot(TM) Client VM 1.6.0-rc-b99;
Visual Web Pack Version = 070109

The bug is fixed (not reproduced).
Comment 4 _ alexpetrov 2007-01-10 16:21:47 UTC
This bug is verified on environment:
Product Version         = NetBeans IDE 5.5 (Build 200610171010)
Operating System        = Windows XP version 5.1 running on x86
Java; VM;               = 1.6.0-rc; Java HotSpot(TM) Client VM 1.6.0-rc-b99;
Visual Web Pack Version = 070109

The bug is fixed (not reproduced).
Comment 5 Sakthivel Gopal 2007-01-10 17:21:26 UTC
This bug has been fixed and released via Patch on AutoUpdate on Dec-15-2006.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo