Bug 89861 - Bar and value columns in CPU and Memory snapshots should be called differently in header popup.
Bar and value columns in CPU and Memory snapshots should be called differentl...
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All All
: P4 (vote)
: 7.3
Assigned To: Jiri Sedlacek
issues@profiler
bugdb_14489815
: VISUALVM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-22 14:24 UTC by ehucka
Modified: 2012-08-28 02:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ehucka 2006-11-22 14:24:32 UTC
There are two columns in memory Live Results or Snapshot table named Bytes
Allocated. 
I think the first of them (showing percentage in bars) should be named 'Bytes
Allocated [%]' like in CPU Results table.
Comment 1 Jiri Sedlacek 2007-01-03 12:59:19 UTC
The problem is that the bar doesn't display percentage values - highest value 
(for example 50%) is displayed as full-length bar and other bars are 
representing relative difference to that value. The [%] sign could thus be 
misleading.

One possibility is to rename the column to 'Bytes Allocated (rel)', but this is 
too long and would be problematic for Memory Liveness results where many 
columns have to be visible.

Closing as wontfix for now as no problems with column name have been 
experienced and the bar itself seems to be self-explaining enough.
Comment 2 ehucka 2007-01-03 13:33:10 UTC
verified
Comment 3 Alexander Kouznetsov 2007-02-12 21:31:05 UTC
There is an inconsistency between Memory and CPU snapshot tables, both having
the same columns, but called and scaled differently. The same column for CPU
snapshot is shown with "[%]" suffix and the bars are scaled so 100% is the whole
column width. I don't want to reopen this issue since I can't define which
approach is better but I would like to see consistency between two snapshot UIs.
Comment 4 Alexander Kouznetsov 2007-02-12 21:34:25 UTC
I would like to recommend to add "(bar)" and "(number)" suffixes to menu items
in Hide or Show columns popup and leave column names unchanged. And make CPU
snapshot to use the same scaling for bars.
Comment 5 Jiri Sedlacek 2007-02-12 21:59:02 UTC
I agree with identifying the columns as "(bar)" and "(value)" in header popup,
it is reasonable and useful. But I'm not sure I agree what do you mean by "make CPU
snapshot to use the same scaling for bars". The same as what?
Comment 6 Alexander Kouznetsov 2007-02-12 22:07:50 UTC
For memory snapshot the following rule is used: (citing) highest value 
(for example 50%) is displayed as full-length bar and other bars are 
representing relative difference to that value.

For CPU snapshots, full-length bar is representing 100% value, not the highest
value.

This is the inconsistency I'm talking about, and I like the approach used for
memory snapshots.
Comment 7 Tomas Hurka 2007-11-07 10:36:48 UTC
Changing target milestone to dev, since NetBeans 6.0 is in high resistance mode.
Comment 8 Tomas Hurka 2009-04-08 12:53:52 UTC
Milestone cleanup: future->next
Comment 9 Jiri Sedlacek 2012-08-21 13:53:02 UTC
Addressed by adding [%] badge to memory views and switching to percentage bars for both CPU and memory results.

Fixed by http://hg.netbeans.org/profiler-main/rev/13c9c1bfaf94.
Comment 10 Quality Engineering 2012-08-28 02:39:42 UTC
Integrated into 'main-golden', will be available in build *201208280001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/13c9c1bfaf94
User: Jiri Sedlacek <jis@netbeans.org>
Log: Bugfix #89861 - percentage bar for memory results, [%] badge for bar column


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo