Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 89718 - Confusing output for running process. Process is not shown in Runtime tab.
Confusing output for running process. Process is not shown in Runtime tab.
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
5.x
All Linux
: P2 (vote)
: 6.x
Assigned To: _ gordonp
issues@cnd
projectsystem
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-21 07:55 UTC by alexandrov
Modified: 2007-12-26 11:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexandrov 2006-11-21 07:55:43 UTC
On sqao35 in /export/home/tester/ the application with name Application3 were
created. It contains the only file  newmain.cc with code:

#include <stdio.h>
#include <stdlib.h>
int main(int argc, char** argv) {
   char line[10];
    scanf("%s", line);
   printf("smth");
   return (EXIT_SUCCESS);
}

If I start "vncviewer  sqao35.sfbay:2" and run netbeans there. Open Application3
and run it(default project "Running" properties were used) I will receive the
ubnormal behavior. External console just appeared, but  in internal output
window I've already watched "Run successful. Exit value 0.". In Runtime tab
there is no this process application3. But I can find it in list of machine
processes. Then I can input "blablabla"  to external console, read "smth", push
Enter and process application3 will be really finished. But Netbeans user
thought that this process were finished much earliar... 
There is the opinion that this bug is due to gnome-terminal version(2.7.3). But
we have example when this bug is reproducible for gnome-terminal 2.6.1
Comment 1 _ gordonp 2007-03-02 22:36:11 UTC
Fixed at start of 5.5.1.
Comment 2 soldatov 2007-12-26 11:09:35 UTC
verified in 200712260000 build


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo