Bug 89497 - Pure java svn client.
Pure java svn client.
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
5.x
All All
: P3 with 5 votes (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-16 17:44 UTC by abs
Modified: 2010-11-25 10:56 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abs 2006-11-16 17:44:14 UTC
I think pure java svn client is very useful. If subversion module use pure java
svn client, it is really easy to configure svn feature.(We don't need to install
OS native client.)

And if we use pure java svn client, we can resolve many problems more flexibly
especially i18n.
Comment 1 Tomas Stupka 2007-01-02 10:32:20 UTC

*** This issue has been marked as a duplicate of 75339 ***
Comment 2 abs 2007-01-03 05:43:14 UTC
Issue 75339 talk about not only pure java svn alternatives. And I think SVNKit
has licensing problem. So issue 75339 is similar to this issue but different.

Because only pure java client resolve installation and configuration problem. On
Mac OS X some user report problem to use subversion module. And I also
experienced problem to use subversion module on Mac OS X.

Many people already voted this issue. User's request is pure java client. So I
think this issue should be re-opened. And subversion module should use pure java
client, not other alternatives.
Comment 3 Tomas Stupka 2007-01-17 09:39:10 UTC
as much i know - svnkit is a pure java client.

however, are you suggesting we should create our own implementation or do you
know some another alternative?

Comment 4 abs 2007-01-17 17:04:22 UTC
What is your opinion about SVNKit licensing issue?

I think there is no other alternative. So if we can't adopt SVNKit because of
licensing issue, I think NetBeans own pure java svn client is necessary.

I don't insist on developing own pure java svn client. I just want to use pure
java svn client.
Comment 5 gborkowski 2007-01-17 18:00:35 UTC
I really don't understand. If SVNKit is used by Eclipse, Idea, JDeveloper (and
this information is published on SVNKit home page) and others, what's the
problem with NetBeans?
Comment 6 Tomas Stupka 2007-01-18 09:40:58 UTC
netbeans is running under a different lincense and it wasn't compatible with the
svnkits the last time this was evaluated. The thing is that the NB lincese
changed since then so using the svnkit could be eventually a subject of a
repeated evaluation. This is one of the alternatives issue #75339 is about.

concerning the pure java client - we are realy no cmd line client fetishists
here:). if there will be a java client we could use, then we will see that it's
going to be supported.

Comment 7 abs 2007-01-20 05:23:10 UTC
License of NetBeans is now CDDL. I talked about this issue in nb-svn mailing list.
http://subversion.netbeans.org/servlets/ReadMsg?list=interest&msgNo=18

People from OpenGrok (that license is CDDL) say, there is licensing issue. So I
think even now, NetBeans can't adopt SVNKit(formerly known as JavaSvn). 

How do you see it?
Comment 8 Tomas Stupka 2007-02-02 09:28:43 UTC
as i'm not lawyer, it isnt't of real value how i see it, but as much i know -
the licences are still incompatible.

the idea was that that we should check this from time to time.
Comment 9 abs 2007-02-02 16:51:27 UTC
So what is your plan of NetBeans 6.0's svn support. Do you still use
command-line svn client?

I think many user start to use subversion and subversion module of NetBeans. So
this client problem is very important. Because if we doesn't adopt pure java
client, many user will confuse to use NetBeans subversion functionality. Other
IDEs already ship pure java client, so they don't need to install additional svn
client. One of the greatest point of NetBeans is, we can use NetBeans
out-of-the-box. So I really need pure java client.
Comment 10 Peter Pis 2008-10-13 09:19:16 UTC
Reopening. Pure java svn client would be of great help on various platforms.
Comment 11 Tomas Stupka 2010-11-25 10:56:32 UTC
http://http://hg.netbeans.org/core-main/rev/89f84e334b73 - just added native java support for subversion - svnkit.

as for now it is not the default setting (will change soon), but you should be already able to take advantage of it by running netbeans with the switch -J-DsvnClientAdapterFactory=svnkit


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo