Bug 89343 - Pause doesn't work on Windows when program waits user input
Pause doesn't work on Windows when program waits user input
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
5.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: _ gordonp
issues@cnd
:
Depends on:
Blocks: 90222
  Show dependency treegraph
 
Reported: 2006-11-14 23:42 UTC by Andrew Krasny
Modified: 2009-06-25 10:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Krasny 2006-11-14 23:42:36 UTC
Steps to reproduce:

- Open NB;
- Create a new project - sample application "Quote"
- Push 'Debug Main Project' button (no need to add any breakpoints) -
application will be compiled and run up to the place when it waits for user nput.
- Push 'Pause' button - nothing happens on Windows.

On other platforms it works - user can see several frames in call stack and that
program was in _read function and that it was called from 
quote.cc:55 (cin >> customerName;)
Comment 1 _ gordonp 2006-11-15 02:07:01 UTC
This problem is caused because when the Windows process gets interrupted its
in an (ugly) Exception stack. I thought this would be very confusing to users
so I silently step until I get back to user code.

In this case, since the interrupted read is reentered, the silent stepping
blocks on the read.
Comment 2 _ gordonp 2007-09-29 22:53:14 UTC
Pause is now working (its instantaneous with MinGW's gdb, but takes 20-30 seconds
with Cygwin's gdb). You can now enter commands and set breakpoints (you can also
now set breakpoints on a running process). The stack displayed at the stop does not
contain user functions and I've filed 117126 for that issue.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo