Bug 89011 - [A11Y][Vista] Options|Keymap loosing focus
[A11Y][Vista] Options|Keymap loosing focus
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Options&Settings
6.x
PC All
: P3 (vote)
: 6.x
Assigned To: rmatous
issues@platform
: A11Y, FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 12:57 UTC by Max Sauer
Modified: 2008-12-22 14:53 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max Sauer 2006-11-09 12:57:50 UTC
Under some circumstances, Options dialog looses focus => mnemonics inside
Tools|Options|Editor|Keymap stop working -- they are up by parent IDE.

Steps to reproduce:
-------------------
1) Open a j2se project
2) Invoke ie Tools|Options|Keymap|Source
3) Choose ie. 'Ref. Code' and press 'Add'
4) Inside appeared dialog, press 'Cancel'
=> IDE has focus instead of options dialog

---
NetBeans IDE Dev (Build 200611081900)
1.6.0-rc; Java HotSpot(TM) Client VM 1.6.0-rc-b100
Windows Vista version 6.0 running on x86
cs_CZ (nb); Cp1250
Comment 1 Vitezslav Stejskal 2006-12-13 04:23:45 UTC
Reproducible on linux/gnome as well. I think it affects all platforms actually.
Comment 2 Jan Jancura 2008-02-27 12:27:49 UTC
Looks like DialogDescriptor issue.
Comment 3 Jiri Rechtacek 2008-02-29 12:36:57 UTC
It looks that Add dialog has wrongly assigned parent window. what affects focus behaviour. Please, ensure Options dialog
is parent of Add dialog. Btw. I cannot reproduce it at 
>System Info: 
  Product Version         = NetBeans IDE Dev (Build 200802270005)
  Operating System        = Linux version 2.6.22-14-generic running on i386
  Java; VM; Vendor        = 1.6.0_04; Java HotSpot(TM) Client VM 10.0-b19; Sun Microsystems Inc.
Comment 4 Vitezslav Stejskal 2008-03-03 10:12:21 UTC
changeset 9bd18238c0fd in main
details: http://hg.netbeans.org/main?cmd=changeset;node=9bd18238c0fd


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo