Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 88775 - Don't save project properties if they were not changed
Don't save project properties if they were not changed
Status: RESOLVED WONTFIX
Product: projects
Classification: Unclassified
Component: Ant Project
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@projects
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 09:59 UTC by Radko Najman
Modified: 2010-04-08 01:59 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Radko Najman 2006-11-07 09:59:49 UTC
Open project properties dialog, don't change any property and press OK button.
The properties are saved -> they should be saved only if any property was
changed, otherwise not.
Comment 1 Milos Kleint 2006-11-07 10:18:15 UTC
why is this important (P1)? is there something which clashes with the current
functionality?
Comment 2 Radko Najman 2006-11-07 11:04:16 UTC
Because if you click OK, the dialog disappears and you can see only a gray
rectangle for a few seconds. It is quite a long time during which the IDE does
not respond. It is very annoying and I remember a few users already complained
about it. Why should I wait 4 second if there is no reason to save the
properties and just close the dialog would be enough?
(BTW it is P1 enhancement, not a defect)
Comment 3 Jesse Glick 2006-11-07 18:46:09 UTC
Which project type(s)? Should probably be filed separately for each type since
they each implement their own dialog.
Comment 4 Radko Najman 2006-11-07 19:35:17 UTC
All project types. I know that each project has own implementation but it would
be nice if we could introduce any common mechanism or support how to solve this
problem. Especially if the number of project types is still growing.
Comment 5 Antonin Nebuzelsky 2006-12-19 12:55:00 UTC
Not planned for 6.0. This is rather a P3 performance bug, not an enhancement,
and it requires large changes.
Comment 6 Jesse Glick 2006-12-19 23:41:41 UTC
Does it really require large changes? I don't see why. I think it should be
considered for fixing in 6.0 if practical, though it's not a big priority.
Comment 7 Milos Kleint 2009-02-13 11:27:41 UTC
reassigning to ant project type support
Comment 8 Jesse Glick 2010-04-08 01:59:28 UTC
Part of saving is determining what files need to be modified; we would need to do that work in any case. Adding an extra code path to try to detect the special case that this set of files is empty would likely lead to bugs. Anyway

1. The normal case is to either make changes, then click OK; or to click Cancel (or just hit Escape). There is no particular reason to click OK when you have not made changes.

2. I do not see any gray rectangle for four seconds. If the UI is really reproducibly being blocked for several seconds just to save project properties, that is a bug in its own right.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo