Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 88654 - JNI support plugin
JNI support plugin
Status: RESOLVED DUPLICATE of bug 133692
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@ide
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-04 21:06 UTC by _ gtzabari
Modified: 2009-11-18 06:16 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2006-11-04 21:06:51 UTC
There has been a recent discussion of making JNI easier to use:
http://www.javalobby.org/forums/thread.jspa?threadID=83696

We need some sort of JNI support plugin that will do things such as
auto-generate C/C++ stub files for native methods defined in Java code and make
it easier to integrate the whole thing as a project (with cross-checking that
native methods exist at compile-time if possible).
Comment 1 Peter Pis 2007-08-31 13:08:30 UTC
Try "cnd" module. Closing as fixed. Feel free to reopen in a case "cnd" support doesn't provide the stuff you call for.
Comment 2 _ gtzabari 2007-08-31 13:49:37 UTC
I took a quick look at the cnd project page and it doesn't look like it does anything I am asking for (yet). Reopening
the issue.
Comment 3 Vladimir Voskresensky 2007-08-31 14:36:07 UTC
cnd doesn't support this yet, but try
http://plugins.netbeans.org/PluginPortal/faces/PluginDetailPage.jsp?pluginid=556
Comment 4 Alexey Vladykin 2009-11-18 06:16:12 UTC

*** This bug has been marked as a duplicate of bug 133692 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo