Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 88510 - Enabling visual web modules hides all JSPs in free form projects!
Enabling visual web modules hides all JSPs in free form projects!
Status: RESOLVED FIXED
Product: obsolete
Classification: Unclassified
Component: visualweb
5.x
All All
: P1 with 1 vote (vote)
: TBD
Assigned To: _ potingwu
issues@obsolete
:
Depends on: 88450
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-02 13:46 UTC by jessholle
Modified: 2007-01-26 20:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Gutted version of free form project causing issues (8.08 KB, application/x-compressed)
2006-11-02 17:12 UTC, jessholle
Details
Projects view shows all JSP files as I tested (6.77 KB, image/gif)
2006-11-02 17:24 UTC, _ potingwu
Details
Files view shows all JSP files as I tested (6.66 KB, image/gif)
2006-11-02 17:25 UTC, _ potingwu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jessholle 2006-11-02 13:46:28 UTC
When the visual web tools preview modules are enabled, all JSP files disappear
from my free-form web project trees.

This occurs in both the projects and files views whether I use "package" or
"tree" views.  The folder in question *is* properly denoted as being a web pages
folder in the free form web project.

This is very easily seen.  Fortunately disabling the visual web modules makes
the JSPs reappear.  Unfortunately, re-enabling them *immediately* makes all the
JSPs disappear once again.

I e-mailed to nbusers and radl@fss.cz replied that he'd done so already with the
same problem and gotten no response.  This is clearly reproducible.
Comment 1 jessholle 2006-11-02 13:52:32 UTC
Not only should the visual web modules not stop free-form web projects from
functioning properly, but the visual web capabilities should be usable from free
form projects.

It took me hours to figure out how to do something approximating a normal web
project's JSP compilation in a free-form project -- and this is still not quite
right.  Examples as to how to wire such things in -- or better yet
auto-generation of such targets to ide-file-targets.xml is necessary.
Comment 2 _ potingwu 2006-11-02 16:46:24 UTC
I can't reproduce here! Could you please give us more details of how we can
reproduece it? It may be caused by your project structure 'uses' the same
identity as VWP but not complete.
Comment 3 jessholle 2006-11-02 17:11:27 UTC
I'm not *using* the Visual Web stuff in any way.  This is just a simple
free-form web project with a "src_web" sub-directory containing my web pages.  I
just installed it meaning to play with it at some point.  I may have updated to
the latest beta thereof as well, which could be the issue.  [How can I dump my
module versions for you?]

I will attach a gutted version of my project that should shed some light on its
arrangement.
Comment 4 jessholle 2006-11-02 17:12:24 UTC
Created attachment 35737 [details]
Gutted version of free form project causing issues
Comment 5 _ potingwu 2006-11-02 17:23:52 UTC
I tried your project and all the JSP files are visible from both the Projects
and Files views! Is that possible you have other NetBeans plugings that conflict
with VWP? Is your installation just NetBeans 5.5 FCS + VWP Pack?
Comment 6 _ potingwu 2006-11-02 17:24:46 UTC
Created attachment 35738 [details]
Projects view shows all JSP files as I tested
Comment 7 _ potingwu 2006-11-02 17:25:26 UTC
Created attachment 35739 [details]
Files view shows all JSP files as I tested
Comment 8 _ potingwu 2006-11-02 18:31:05 UTC
This was fixed on 2006/10/11 (IN=101766).

You should find the following exceptions in message.log, right?

java.io.IOException: java.lang.NullPointerException
	at org.openide.loaders.DataLoader.findDataObject(DataLoader.java:379)
	at org.openide.loaders.DataLoaderPool.findDataObject(DataLoaderPool.java:408)
	at org.openide.loaders.FolderList.createBoth(FolderList.java:707)
	at org.openide.loaders.FolderList.getObjects(FolderList.java:518)
	at org.openide.loaders.FolderList.access$200(FolderList.java:56)
	at org.openide.loaders.FolderList$ListTask.run(FolderList.java:886)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:499)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:932)
Caused by: java.lang.NullPointerException
	at
com.sun.rave.project.jsf.api.JsfProjectUtils.getDocumentRoot(JsfProjectUtils.java:391)
	at
com.sun.rave.project.jsf.api.JsfProjectUtils.getBasePathForJsp(JsfProjectUtils.java:599)
	at
com.sun.rave.project.jsf.api.JsfProjectUtils.getJavaForJsp(JsfProjectUtils.java:505)
	at com.sun.rave.project.jsfloader.Utils.findJavaForJsp(Utils.java:46)
	at
com.sun.rave.project.jsfloader.JsfJspDataLoader.findPrimaryFile(JsfJspDataLoader.java:82)
	at
org.openide.loaders.MultiFileLoader.findPrimaryFileImpl(MultiFileLoader.java:268)
	at
org.openide.loaders.MultiFileLoader.handleFindDataObject(MultiFileLoader.java:71)
	at org.openide.loaders.DataObjectPool.handleFindDataObject(DataObjectPool.java:129)
	at org.openide.loaders.DataLoader.findDataObject(DataLoader.java:364)
	... 7 more
Comment 9 _ potingwu 2006-11-02 18:34:46 UTC
Fixed in trunk.
Comment 10 jessholle 2006-11-02 19:00:55 UTC
That exception looks familiar, yes.

I would have included it in the bug report but I lost the exception
(inexcusable, I know).

I'm glad to hear this has been addressed.  I'm not concerned about the interim
-- I just wanted to make sure this didn't stay broken in future visual web
module updates and/or the final release.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo