Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 88450 - Unable to view the JSP files.
Unable to view the JSP files.
Status: RESOLVED FIXED
Product: obsolete
Classification: Unclassified
Component: visualweb
5.x
All All
: P1 (vote)
: TBD
Assigned To: _ potingwu
issues@obsolete
:
Depends on:
Blocks: 88510 88863
  Show dependency treegraph
 
Reported: 2006-11-01 18:41 UTC by kkandasami
Modified: 2007-01-26 20:36 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (372.90 KB, text/plain)
2006-11-01 18:44 UTC, kkandasami
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kkandasami 2006-11-01 18:41:19 UTC
Getting Nullpointers from the DataLoaders:

java.io.IOException: java.lang.NullPointerException
	at org.openide.loaders.DataLoader.findDataObject(DataLoader.java:379)
	at org.openide.loaders.DataLoaderPool.findDataObject(DataLoaderPool.java:408)
	at org.openide.loaders.FolderList.createBoth(FolderList.java:707)
	at org.openide.loaders.FolderList.getObjects(FolderList.java:518)
	at org.openide.loaders.FolderList.access$200(FolderList.java:56)
	at org.openide.loaders.FolderList$ListTask.run(FolderList.java:886)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:499)
[catch] at
org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:932)
Caused by: java.lang.NullPointerException
	at
com.sun.rave.project.jsf.api.JsfProjectUtils.getDocumentRoot(JsfProjectUtils.java:391)
	at
com.sun.rave.project.jsf.api.JsfProjectUtils.getBasePathForJsp(JsfProjectUtils.java:599)
	at
com.sun.rave.project.jsf.api.JsfProjectUtils.getJavaForJsp(JsfProjectUtils.java:505)
	at com.sun.rave.project.jsfloader.Utils.findJavaForJsp(Utils.java:46)
	at
com.sun.rave.project.jsfloader.JsfJspDataLoader.findPrimaryFile(JsfJspDataLoader.java:82)
	at
org.openide.loaders.MultiFileLoader.findPrimaryFileImpl(MultiFileLoader.java:268)
	at
org.openide.loaders.MultiFileLoader.handleFindDataObject(MultiFileLoader.java:71)
	at org.openide.loaders.DataObjectPool.handleFindDataObject(DataObjectPool.java:129)
	at org.openide.loaders.DataLoader.findDataObject(DataLoader.java:364)
	... 7 more
Comment 1 kkandasami 2006-11-01 18:44:04 UTC
Created attachment 35708 [details]
messages.log
Comment 2 Peter Zavadsky 2006-11-01 19:01:44 UTC
This belongs to project.
Comment 3 _ potingwu 2006-11-01 19:07:01 UTC
This was fixed on 2006/10/11 (IN=101766).
Comment 4 kkandasami 2006-11-03 19:18:57 UTC
Guys !!

I downloaded the latest from the netbeans.org, when 5.5 was release.

I don't think I can get a daily build of visual web pack nor.. I could build
from source which has no reference in the nbbuild.netbeans.org.

Help me here...how to proceed.
Comment 5 _ potingwu 2006-11-03 19:25:12 UTC
Patch for this fix will be released soon, hopefully next week.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo