Bug 88400 - Hook for a custom refresh action
Hook for a custom refresh action
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Palette
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
plan60
:
Depends on: 96672
Blocks: 90211
  Show dependency treegraph
 
Reported: 2006-11-01 10:59 UTC by David Kaspar
Modified: 2008-12-22 14:47 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kaspar 2006-11-01 10:59:46 UTC
Currently there is a Refresh popup menu item on a palette.
The action is refreshing just a content of a palette folder in layer.

In some cases the content of a palette folder in the layer is created based on
another data.

By invoking "Refresh Palette" action, it should be possible to perform a custom
refresh action that does the real refresh of root data.
Comment 1 Stanislav Aubrecht 2006-11-06 10:54:19 UTC
this is not a bug, API must be enhanced to allow this action
Comment 2 Antonin Nebuzelsky 2006-12-19 17:05:14 UTC
Let's talk about this more and possibly evaluate for 6.0.
Comment 3 Anton Chechel 2007-01-22 13:44:45 UTC
We are using it in Visual Designer for Mobility Pack and need it for 6.0.
Comment 4 Stanislav Aubrecht 2007-03-06 09:25:57 UTC
the new api is now available, see #96672


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo