Bug 87976 - Getting nodes of logical view's node does not work reliably in tests
Getting nodes of logical view's node does not work reliably in tests
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Krauskopf
issues@apisupport
: RANDOM, TEST, THREAD
: 89049 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 16:14 UTC by Martin Krauskopf
Modified: 2007-10-02 10:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
assertion (1.66 KB, text/plain)
2006-10-25 16:15 UTC, Martin Krauskopf
Details
Attaching one more exception. Obviously the same (famous) problem with children keys. (1.67 KB, text/plain)
2007-02-23 09:58 UTC, Martin Krauskopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Krauskopf 2006-10-25 16:14:42 UTC
This one is random. See attachment.
Comment 1 Martin Krauskopf 2006-10-25 16:15:33 UTC
Created attachment 35542 [details]
assertion
Comment 2 Martin Krauskopf 2007-02-23 09:58:04 UTC
Created attachment 38855 [details]
Attaching one more exception. Obviously the same (famous) problem with children keys.
Comment 3 Martin Krauskopf 2007-08-17 12:38:11 UTC
This is general problem in bunch of tests. And is the same for all of them. Once solved it will work for all of them. We
just need a trick to achieve children refresh/load. Currently it seems that even 'ping' trick stops to work completely
(not RANDOM, I think). I'll try to ask, probably Petr Nejedly, when I meet him.
Comment 4 Martin Krauskopf 2007-08-17 12:39:40 UTC
*** Issue 89049 has been marked as a duplicate of this issue. ***
Comment 5 Martin Krauskopf 2007-10-02 10:59:23 UTC
Something is fixed. Will fix other as/if they fail.

src/org/netbeans/modules/apisupport/project/ui/ImportantFilesNodeFactory.java;
new revision: 1.6; previous revision: 1.5
test/unit/src/org/netbeans/modules/apisupport/project/TestBase.java;
new revision: 1.51; previous revision: 1.50
test/unit/src/org/netbeans/modules/apisupport/project/ui/LibrariesNodeTest.java;
new revision: 1.11; previous revision: 1.10
test/unit/src/org/netbeans/modules/apisupport/project/ui/ModuleLogicalViewTest.java;
new revision: 1.17; previous revision: 1.16



By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo