Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 87874 - auto-creating a method disables editing
auto-creating a method disables editing
Status: RESOLVED DUPLICATE of bug 65326
Product: platform
Classification: Unclassified
Component: Window System
5.x
Macintosh Mac OS X
: P2 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 15:07 UTC by santafen
Modified: 2008-12-22 19:37 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
complete log file from 5.5RC2 (945.09 KB, text/plain)
2006-10-24 17:16 UTC, santafen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description santafen 2006-10-24 15:07:36 UTC
If I allow the editor to create a method in  another class for me, editing of ALL source files immediately 
and permanently ceases. I have to restart the IDE to be able to further edit code. 

This is a HUGE PITA and makes using NetBeans to auto-create methods in other classes useless.

Error in the log file is thrown: 
INFORMATIONAL *********** Exception occurred ************ at 10:06 AM on Oct 24, 2006
Annotation: From file: MultiFileObject@bbb60d[Actions/Window/com-sun-SPOTwelcomemodule-
SPOTWelcome.instance]
java.lang.ClassNotFoundException: com.sun.SPOTwelcomemodule.SPOTWelcome
        at org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:159)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
        at org.openide.loaders.InstanceSupport.findClass(InstanceSupport.java:475)
        at org.openide.loaders.InstanceSupport.instanceClass(InstanceSupport.java:125)
        at org.openide.loaders.InstanceDataObject$Ser.instanceClass(InstanceDataObject.java:1170)
        at org.openide.loaders.InstanceSupport.instanceOf(InstanceSupport.java:163)
        at org.openide.loaders.InstanceDataObject$Ser.instanceOf(InstanceDataObject.java:1193)
        at org.openide.loaders.InstanceDataObject.instanceOf(InstanceDataObject.java:721)
        at org.openide.awt.Toolbar$Folder.acceptCookie(Toolbar.java:941)
        at org.openide.loaders.FolderInstance.acceptDataObject(FolderInstance.java:363)
        at org.openide.awt.Toolbar$Folder.acceptDataObject(Toolbar.java:908)
        at org.openide.loaders.FolderInstance.defaultProcessObjects(FolderInstance.java:650)
        at org.openide.loaders.FolderInstance.access$000(FolderInstance.java:68)
        at org.openide.loaders.FolderInstance$2.run(FolderInstance.java:622)
        at org.openide.util.Task.run(Task.java:216)
        at org.openide.awt.AWTTask.run(AWTTask.java:29)
        at org.openide.awt.AWTTask.waitFinished(AWTTask.java:36)
        at org.openide.loaders.FolderInstance.waitFinished(FolderInstance.java:292)
        at org.openide.loaders.FolderInstance.instanceCreate(FolderInstance.java:234)
        at org.openide.loaders.FolderInstance.instanceForCookie(FolderInstance.java:515)
        at org.openide.loaders.FolderInstance$HoldInstance.instanceCreate(FolderInstance.java:1000)
        at org.openide.awt.ToolbarPool$Folder.createInstance(ToolbarPool.java:500)
        at org.openide.loaders.FolderInstance.defaultProcessObjects(FolderInstance.java:736)
        at org.openide.loaders.FolderInstance.access$000(FolderInstance.java:68)
        at org.openide.loaders.FolderInstance$2.run(FolderInstance.java:622)
        at org.openide.util.Task.run(Task.java:216)
        at org.openide.awt.AWTTask.run(AWTTask.java:29)
        at org.openide.awt.AWTTask.waitFinished(AWTTask.java:36)
        at org.openide.loaders.FolderInstance.waitFinished(FolderInstance.java:292)
        at org.openide.loaders.FolderInstance.instanceFinished(FolderInstance.java:265)
        at org.openide.awt.ToolbarPool.waitFinished(ToolbarPool.java:217)
        at org.netbeans.core.windows.view.ui.MainWindow.getToolbarComponent(MainWindow.java:395)
        at org.netbeans.core.windows.view.ui.MainWindow.initializeComponents(MainWindow.java:147)
        at org.netbeans.core.windows.view.DefaultView.showWindowSystem(DefaultView.java:500)
        at org.netbeans.core.windows.view.DefaultView.windowSystemVisibilityChanged(DefaultView.java:
479)
        at org.netbeans.core.windows.view.DefaultView.changeGUI(DefaultView.java:163)
        at org.netbeans.core.windows.ViewRequestor.dispatchRequest(ViewRequestor.java:238)
        at org.netbeans.core.windows.ViewRequestor.processVisibilityRequest(ViewRequestor.java:227)
        at org.netbeans.core.windows.ViewRequestor.postVisibilityRequest(ViewRequestor.java:164)
        at org.netbeans.core.windows.ViewRequestor.scheduleRequest(ViewRequestor.java:85)
        at org.netbeans.core.windows.Central.setVisible(Central.java:74)
        at org.netbeans.core.windows.WindowManagerImpl.setVisible(WindowManagerImpl.java:710)
        at org.netbeans.core.windows.WindowSystemImpl.show(WindowSystemImpl.java:56)
[catch] at org.netbeans.core.NonGui$3.run(NonGui.java:223)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
        at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

But this says it is from Actions/Window/com-sun-SPOTwelcomemodule-SPOTWelcome.instance]
 which is not the currently open project. Totally FUBAR
Comment 1 santafen 2006-10-24 15:19:06 UTC
Occurs *Exactly* the same in 5.5RC2
Comment 2 Jiri Prox 2006-10-24 17:10:38 UTC
Can you provide the whole messages.log, please?
Comment 3 santafen 2006-10-24 17:16:06 UTC
Created attachment 35502 [details]
complete log file from 5.5RC2
Comment 4 Jiri Prox 2006-10-24 18:09:56 UTC
I don't see any problems in the log, there are only info. exception from
subversion, which is ok. Please can you provide more information: 
Does it happen always or is is random? Does it happen with new project and/or
userdir?  Thanks in advance.
Comment 5 santafen 2006-10-24 18:16:15 UTC
It happens always. It was happening always on 5.0, so I did a brand new installation of 5.5RC2 and it 
continued. Always. Every time. But ONLY if the method being created is in a different class (File) than the 
current file. Creating methods/fields in the CURRENT file seems to work fine.
Comment 6 Jaromir Uhrik 2006-10-25 10:41:40 UTC
It is reproducible on my Mac OS by following steps:
1. Create classes XXX, YYY
2. In YYY constructor type XXX xxx = new XXX();
3. Continue typing xxx.someNonExistingMethod();
4. Click on editor hint bulb and select by mouse click item "Create method 
xxx.someNonExistingMethod() in YYY".
5. The editor freezes - better to say it doesn't get focus

I found 2 workarounds:
1.Don't use mouse for selecting of hints (use keyboard Alt+Enter instead) - then
the issue doesn't appear
2.You don't need restart - editor can be accessed after some dialog is opened
and closed (e.g open and close Update Center Wizard or New Project Wizard)

Downcreasing issue to P2.
Guessing it is a duplicate of #60235. Milosi could you mark it as duplicate if I
am right.
Comment 7 Milos Kleint 2006-10-27 08:13:04 UTC
rather a duplicate of #65326. it's an apple jdk issue. I filed it into their bug
tracking system. The mentioned workarounds apply.



*** This issue has been marked as a duplicate of 65326 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo