Bug 87841 - removed nested class is not removed from diagram
removed nested class is not removed from diagram
Status: VERIFIED DUPLICATE of bug 80569
Product: uml
Classification: Unclassified
Component: Reverse Engineering
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Yang Su
issues@uml
55uml_beta_rn, GRIFFIN_CANDIDATE
: RELNOTE
Depends on: 82727
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 12:37 UTC by Andrew Korostelev
Modified: 2007-09-14 00:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Korostelev 2006-10-24 12:37:06 UTC
User has java project with nested class and RE'ed uml project with class digram,
that shows outer and inner classes.
If user removes nested class from source and performs RE to the same uml
project, removed nested class is still shown on diagram.

workaround: close and reopen diagram. Nested class will disappear.

steps to reproduce:
- Create an empty Java project
- Add 'pack' package into the Java project
- Add 'OuterClass'  class under the package
  -----------------------------------------------------------
  package pack;

  public class OuterClass {
    class InnerClass{
    }
  }
  -----------------------------------------------------------
- Reverse Engineer the Java project into UML project
- Create a Class diagram
- Darg and Drop 'OuterClass' and 'OuterClass|InnerClass' on the
  diagram.
- Go to the Java project
- Remove InnerClass from source file
  -----------------------------------------------------------
  package pack;
  public class OuterClass {
  }
  -----------------------------------------------------------
- Reverse Engineer the Java project into the existing UML project
- Go to the Class diagram
BUG: 'InnerClass' and nested link to 'OuterClass' are still displayed.
 It is problem of diagram refreshing, because Inner class is removed from model.
Comment 1 Kris Richards 2006-12-18 22:11:23 UTC
The "InnerClass" class is no longer an element in the model, but it still appears on the diagram.
Comment 2 Peter Lam 2007-03-20 23:35:27 UTC
low use case not currently impacting our installed user base.
Comment 3 Yang Su 2007-07-17 23:38:52 UTC

*** This issue has been marked as a duplicate of 80569 ***
Comment 4 Peter Lam 2007-09-14 00:01:49 UTC
verified in build 20070913.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo