Bug 87684 - Need error annotations like in Java editing (syntax error highlighting)
Need error annotations like in Java editing (syntax error highlighting)
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Code Model
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Vladimir Kvashin
issues@cnd
CND-BUG-A-THON error_hl
: PLAN
: 129648 (view as bug list)
Depends on: 86760 135793 135798 135964 136398
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-20 19:12 UTC by _ gordonp
Modified: 2008-07-29 11:06 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gordonp 2006-10-20 19:12:01 UTC
> No live error annotations like we have in Java editor

Note: I make subcomponent "codemodel" rather than "editor" because the
codemodel group will need to provide this information.
Comment 1 Vladimir Kvashin 2008-05-12 10:42:40 UTC
*** Issue 129648 has been marked as a duplicate of this issue. ***
Comment 2 Quality Engineering 2008-05-27 16:27:18 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #221 build
Changeset: http://hg.netbeans.org/main/rev/0f992b5a09dc
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: Using parser errors as a source of error highlighting, initial variant  (#87684 Need error annotations)
Swithced OFF by default: to switch ON use -J-Dcnd.parser.error.provider=true
Comment 3 Quality Engineering 2008-05-28 16:13:35 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #223 build
Changeset: http://hg.netbeans.org/main/rev/cb2005295235
User: Vladimir Kvashin <vkvashin@netbeans.org>
Log: Error highlighting process bodies as well   (#87684 Need error annotations)
(Pls note that the feature is swithced OFF by default; to switch ON use -J-Dcnd.parser.error.provider=true)
Comment 4 Vladimir Kvashin 2008-06-03 13:38:51 UTC
The detailed plan:
http://wiki.netbeans.org/CNDErrorHighlighting


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo