Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 87380 - Cannot add a GlassFish 9.1 cluster enabled server to the NetBeans Runtime Tab.
Cannot add a GlassFish 9.1 cluster enabled server to the NetBeans Runtime Tab.
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: Sun Appserver 9
5.x
All All
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
GFV2, release55_fixes_fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-18 08:01 UTC by Gopalan Raj
Modified: 2007-02-19 11:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Error on Adding a Clustered GlassFish 9.1 Server instance (build 21) to NB Runtime Tab (66.17 KB, image/png)
2006-10-18 08:05 UTC, Gopalan Raj
Details
GlassFish 9.1 build 21 on Windows XP (192.10 KB, image/png)
2006-10-18 08:14 UTC, Gopalan Raj
Details
diff patch for 5.5.1 (4.27 KB, text/plain)
2006-11-21 19:56 UTC, Vince Kraemer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gopalan Raj 2006-10-18 08:01:09 UTC
Cannot add a GlassFish 9.1 cluster enabled server to the NetBeans Runtime Tab.

NetBeans 5.5 not able to add the new AppServer 9.1 clustered edition. 

Trying to add such a server fails with a "Software cause connection abort:recv
failed." error.

However, one is able to add a non-cluster enabled GlassFish 9.1 to the NetBeans
Runtime Tab.

<speculation>
The problem might be that if you set the server up for clustering you have to go
through the HTTPS connector. On the other hand if it is not setup for
clustering, you go through the regular HTTP Connector.
</speculation>

This was tested with clustered GlassFish 9.1 build 21.
Comment 1 Gopalan Raj 2006-10-18 08:05:53 UTC
Created attachment 35311 [details]
Error on Adding a Clustered GlassFish 9.1 Server instance (build 21) to NB Runtime Tab
Comment 2 Gopalan Raj 2006-10-18 08:14:33 UTC
Created attachment 35312 [details]
GlassFish 9.1 build 21 on Windows XP
Comment 3 Petr Blaha 2006-10-18 09:27:49 UTC
NetBeans 5.5 supports only AS (GF) 9.0 u1 only. This GF version doesn't support
clustering yet. This issue will be definitely resolved in NetBeans 6.0. I
suggest to downgrade priority.
Comment 4 Petr Jiricka 2006-10-18 09:37:29 UTC
Agreed, changing priority to P2, as AS 9.1 is not a supported server for
NetBeans 5.5.
Comment 5 Vince Kraemer 2006-10-18 21:01:44 UTC
investigating
Comment 6 Vince Kraemer 2006-10-19 06:37:19 UTC
it looks like GF changed the way it behaves when somebody connects to its http
port and that port is secure...
Comment 7 Vince Kraemer 2006-10-20 08:46:25 UTC
5.5 plugin backport candidate

tested against: V1U1 (unsecured), V2 (setup-cluster.xml), V2 (setup.xml) and
sjsas 8.2 (pe).

Was able to register/start/stop/deploy and execute simple stuff using the
plugin's functional test suite.

manual test of V1U1 (secured) register/start/stop/deploy.

More cleanup required later: http://www.netbeans.org/issues/show_bug.cgi?id=87602

Checking in SunDeploymentManager.java;
/cvs/serverplugins/sun/appsrv81/src/org/netbeans/modules/j2ee/sun/ide/dm/SunDeploymentManager.java,v
 <--  SunDeploymentManager.java
new revision: 1.26; previous revision: 1.25
done
Comment 8 Petr Blaha 2006-10-24 08:48:41 UTC
No objections for waiver, marking as approved.
Comment 9 Vince Kraemer 2006-11-03 18:16:36 UTC
integrated into release55_fixes at request of ent pack folks.

Checking in appsrv/src/org/netbeans/modules/j2ee/sun/appsrvapi/PortDetector.java;
/cvs/serverplugins/sun/appsrv/src/org/netbeans/modules/j2ee/sun/appsrvapi/PortDetector.java,v
 <--  PortDetector.java
new revision: 1.1.16.2.2.2.22.1; previous revision: 1.1.16.2.2.2
done
Checking in
appsrv81/src/org/netbeans/modules/j2ee/sun/ide/dm/SunDeploymentManager.java;
/cvs/serverplugins/sun/appsrv81/src/org/netbeans/modules/j2ee/sun/ide/dm/SunDeploymentManager.java,v
 <--  SunDeploymentManager.java
new revision: 1.10.4.5.2.17.6.1; previous revision: 1.10.4.5.2.17
done
Comment 10 Vince Kraemer 2006-11-21 19:56:11 UTC
Created attachment 36184 [details]
diff patch for 5.5.1
Comment 11 Vince Kraemer 2006-11-21 19:58:47 UTC
The patch includes the cleanup for 
http://www.netbeans.org/issues/show_bug.cgi?id=87602.
Comment 12 Vince Kraemer 2006-11-22 19:30:58 UTC
waiting for verification and code review for inclusion in release551.
Comment 13 judytang 2006-11-27 22:02:47 UTC
I have tested with Vince's fix, I can add the AppServer 9.1 EE to NetBeans 5.5 and
NetBeans 6.0.  
Comment 14 Vince Kraemer 2006-11-29 04:34:41 UTC
Checking in appsrv/src/org/netbeans/modules/j2ee/sun/appsrvapi/PortDetector.java;
/cvs/serverplugins/sun/appsrv/src/org/netbeans/modules/j2ee/sun/appsrvapi/PortDetector.java,v
 <--  PortDetector.java
new revision: 1.1.16.2.2.2.26.1; previous revision: 1.1.16.2.2.2
done
Checking in
appsrv81/src/org/netbeans/modules/j2ee/sun/ide/dm/SunDeploymentManager.java;
/cvs/serverplugins/sun/appsrv81/src/org/netbeans/modules/j2ee/sun/ide/dm/SunDeploymentManager.java,v
 <--  SunDeploymentManager.java
new revision: 1.10.4.5.2.17.10.1; previous revision: 1.10.4.5.2.17
done
Comment 15 Vince Kraemer 2006-11-29 04:37:46 UTC
NOTE CONCERNING TESTING:

There is another issue in V2, that will prevent you from being able to verify
this fix if you use a nightly build that is newer than 2006-11-20.  The issue is
https://glassfish.dev.java.net/issues/show_bug.cgi?id=1595.  There is commitment
from the server team to resolve this in the GF codebase.
Comment 16 judytang 2006-12-04 21:31:41 UTC
I am using win XP, and I use JDK 1.5 which is bundled in 9.1 EE

Using NB 5.5 FCS build, I could not recreate this reported issue with both AS
9.1 EE promote build 26 and Glassfish EE promoted build 26.

(1) To this issue reporter, could you please try the AS/Glassfish latest
promoted build 26 to see if this issue still exists or not.

(2) To the developer, could you please check with AS developer to see what has
been fixed in build 26 to address this issue.  It could be some thing I missed
some where too, if so please let me know.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo