Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 86858 - Repaint problems on MacOS with JDK 1.6
Repaint problems on MacOS with JDK 1.6
Status: RESOLVED DUPLICATE of bug 86850
Product: installer
Classification: Unclassified
Component: Code
5.x
All Mac OS X
: P2 (vote)
: 5.x
Assigned To: Kirill Sorokin
issues@installer
55EP_RR_DOCS
: RELNOTE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-10 14:15 UTC by Mikhail Kondratyev
Modified: 2007-02-16 13:30 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Kondratyev 2006-10-10 14:15:55 UTC
Steps to reproduce:
 - run Netbeans with jdk 1.6 specified
 - in the project tree, try to drag the Runtime tab to some other position
When dragging the tab, you will see black aquare area being dragged, after you
drop it somewhere there will be problems with Welcome screen repainting

You can reproduce the repaint problems with any other window and with oher
actions. Sometimes the IDE becomes unusable because of these problems.

Workaround: when running the IDE set -J-Dapple.awt.graphics.UseQuartz=true
or use java 1.5

We can avoid this bug if installer sets the UseQuartz option to true during install
Comment 1 Mikhail Kondratyev 2006-10-10 14:19:28 UTC
More detailed description steps:
 - install Enterprise Tools Bundle on MacOS and specify jdk 1.6 to be used by IDE
 - run the IDE
 - in the project tree, try to drag the Runtime tab to some other position
There will be problems repainting the Welcome screen and other windows 
Comment 2 dlipin 2006-10-13 18:00:51 UTC
Mike,
Is this issue is reproducible with the pure NetBeans IDE or only with Java Tools 
Bundle/NetBeans IDE + EntPack? If the answer is NO (the issue is NOT 
reproducible with pure NetBeans IDE) that all the next written stuff should be 
ignored.

I do think that this key should not be added by EntPack/JavaTools installer. 
There is no special installer for NetBeans IDE on MacOSX, it is delivered as .
tar.gz file. So the IDE "installer" on MacOSX can`t even add this flag to 
netbeans.conf. As for configuring IDE we (EntPack/JavaTools installer) try to 
behave in the same maner as IDE installer does. So it is not desirable for us to 
do the things about IDE that differs from IDE installer itself.

Most probably this should be added to release notes or just add as a comment to 
netbeans.conf.
So I think that ide/documentation is the right component/subcomponent to 
reassign this issue to.

Thanks,
Dmitry
Comment 3 Mikhail Kondratyev 2006-10-13 19:01:45 UTC
This is reproducible with pure Netbeans installation too.
A similar bug is filed against Netbeans.
I don't mind release noting this but as far as I know the corresponding Netbeans
bug will be releasenoted. Adding whiteboard key for docs to track this.
Comment 4 Annette Wegscheider 2006-10-20 17:10:33 UTC
The current NB 5.5 release notes do not mention this issue at all. See
http://nbstaging.czech.sun.com/community/releases/55/relnotes.html
mikk, please add the # of the issue in NetBeans so we can reference it.
Comment 5 Kirill Sorokin 2006-10-20 17:33:48 UTC
http://www.netbeans.org/issues/show_bug.cgi?id=86850
Comment 6 astashkova 2006-10-23 11:00:26 UTC
No reply regarding the issue from NetBeans IDE 5.5 Release Notes owner received.

Added to RNs.
Use the following link to review the wording and location of the issue in the
staged  NB Ent Pack Release Notes
http://nbstaging.czech/community/releases/55/entpack_relnotes.html#86858
Comment 7 dlipin 2007-02-12 10:07:07 UTC
The issue should be added to the EntPack 5.5.1 Beta release notes.
Comment 8 dlipin 2007-02-13 17:03:44 UTC
closing as the duplicate of the core UI issue.

*** This issue has been marked as a duplicate of 86850 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo