Bug 8680 - The JSP page execution doesn't work if the JSP page was compiled previously.
The JSP page execution doesn't work if the JSP page was compiled previously.
Status: CLOSED FIXED
Product: javaee
Classification: Unclassified
Component: Code
3.x
PC All
: P1 (vote)
: TBD
Assigned To: issues@javaee
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-30 14:41 UTC by Marek Fukala
Modified: 2002-07-19 15:28 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Fukala 2000-11-30 14:41:42 UTC
If you create new JSP page from template and execute it without previous
compilation the execution works fine. But if you compile the JSP page and then
try to execute the JSP page only "Errors compiling xxxx" message appear in
status line and no JSP is executed.
This problem cause that any JSP page can't be executed more than one times if
you do not change the page content. If you do a change in JSP page and then
execute it again it works.
Example how to reproduce:
1) create new JSP page from tamplate
2) execute it
3) execute it again => execution doesn't work

or

1) create a JSP page
2) compile it
3) execute it => exec.dosn't work.
Comment 1 Marek Fukala 2000-11-30 14:48:59 UTC
I made a mistake in previous description. A correction is here:
If you execute a JSP page and the chanhe its content and execute it again the
execution doesn't fail - the browser appear but contain only error message:
Compilation of the requsted JSP page fail. Please see compilation errors in
output window.
Unfortunately the output window contain neither an exception nor any error
message.
Comment 2 Marek Fukala 2000-11-30 14:56:59 UTC
[build 18]
Comment 3 Petr Jiricka 2000-12-04 07:31:59 UTC
*** Bug 8017 has been marked as a duplicate of this bug. ***
Comment 4 Petr Jiricka 2000-12-07 17:04:59 UTC
Fixed in [84].


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo