Bug 86342 - Unable to create webservice client from WSDL for GoogleSearch
Unable to create webservice client from WSDL for GoogleSearch
Status: VERIFIED WONTFIX
Product: webservices
Classification: Unclassified
Component: Client
5.x
All All
: P1 (vote)
: 5.x
Assigned To: issues@webservices
issues@webservices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-02 22:47 UTC by lucyli
Modified: 2007-02-02 19:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
GoogleSearch.wsdl (7.51 KB, application/octet-stream)
2006-10-02 22:48 UTC, lucyli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lucyli 2006-10-02 22:47:55 UTC
With NB 5.5 Dev Build 20060926 

+ create New Web Application
+ Right click on "Web Pages" , choose New> Add WebService from WSDL
+ Choose the attached GoogleSearch.wsdl and click finish (with other inputs like
packagename,..)
Get this:
init:
wsimport-init:
Created dir: C:\Documents and
Settings\Lucy\WebApplication14\build\generated\wsimport\service
Created dir: C:\Documents and
Settings\Lucy\WebApplication14\build\web\WEB-INF\classes
wsimport-service-check-WS:
wsimport-service-WS:
command line: wsimport -d "C:\Documents and
Settings\Lucy\WebApplication14\build\web\WEB-INF\classes" -extension -keep -s
"C:\Documents and
Settings\Lucy\WebApplication14\build\generated\wsimport\service" -catalog
"C:\Documents and Settings\Lucy\WebApplication14\catalog.xml" -verbose
"C:\Documents and
Settings\Lucy\WebApplication14/src/conf/xml-resources/web-services/WS/wsdl/GoogleSearch.wsdl"
warning: src-resolve.4.2: Error resolving component 'soapenc:Array'. It was
detected that 'soapenc:Array' is in namespace
'http://schemas.xmlsoap.org/soap/encoding/', but components from this namespace
are not referenceable from schema document
'file:/C:/Documents%20and%20Settings/Lucy/WebApplication14/src/conf/xml-resources/web-services/WS/wsdl/GoogleSearch.wsdl#types?schema1'.
If this is the incorrect namespace, perhaps the prefix of 'soapenc:Array' needs
to be changed. If this is the correct namespace, then an appropriate 'import'
tag should be added to
'file:/C:/Documents%20and%20Settings/Lucy/WebApplication14/src/conf/xml-resources/web-services/WS/wsdl/GoogleSearch.wsdl#types?schema1'.
  line ? of
file:/C:/Documents%20and%20Settings/Lucy/WebApplication14/src/conf/xml-resources/web-services/WS/wsdl/GoogleSearch.wsdl#types?schema1

error: undefined simple or complex type 'soapenc:Array'
  line 0 of
file:/C:/Documents%20and%20Settings/Lucy/WebApplication14/src/conf/xml-resources/web-services/WS/wsdl/GoogleSearch.wsdl#types?schema1

error: undefined attribute 'soapenc:arrayType'
  line 0 of
file:/C:/Documents%20and%20Settings/Lucy/WebApplication14/src/conf/xml-resources/web-services/WS/wsdl/GoogleSearch.wsdl#types?schema1

error: undefined simple or complex type 'soapenc:Array'
  line 0 of
file:/C:/Documents%20and%20Settings/Lucy/WebApplication14/src/conf/xml-resources/web-services/WS/wsdl/GoogleSearch.wsdl#types?schema1

error: undefined attribute 'soapenc:arrayType'
  line 0 of
file:/C:/Documents%20and%20Settings/Lucy/WebApplication14/src/conf/xml-resources/web-services/WS/wsdl/GoogleSearch.wsdl#types?schema1

org.xml.sax.SAXParseException: undefined attribute 'soapenc:arrayType'
        at
com.sun.tools.ws.processor.modeler.wsdl.WSDLModeler.buildModel(WSDLModeler.java:212)
        at com.sun.tools.ws.processor.config.ModelInfo.buildModel(ModelInfo.java:87)
        at com.sun.tools.ws.processor.Processor.runModeler(Processor.java:81)
        at com.sun.tools.ws.wscompile.CompileTool.run(CompileTool.java:543)
        at com.sun.tools.ws.util.ToolBase.run(ToolBase.java:56)
        at com.sun.tools.ws.ant.WsImport.execute(WsImport.java:419)
        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
        at org.apache.tools.ant.Task.perform(Task.java:364)
        at org.apache.tools.ant.Target.execute(Target.java:341)
        at org.apache.tools.ant.Target.performTasks(Target.java:369)
        at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
        at
org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
        at
org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:240)
        at
org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:293)
        at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:131)
Caused by: org.xml.sax.SAXParseException: undefined attribute 'soapenc:arrayType'
        at
com.sun.tools.ws.processor.modeler.wsdl.JAXBModelBuilder.bind(JAXBModelBuilder.java:128)
        at
com.sun.tools.ws.processor.modeler.wsdl.WSDLModeler.buildJAXBModel(WSDLModeler.java:2206)
        at
com.sun.tools.ws.processor.modeler.wsdl.WSDLModeler.internalBuildModel(WSDLModeler.java:223)
        at
com.sun.tools.ws.processor.modeler.wsdl.WSDLModeler.buildModel(WSDLModeler.java:180)
        ... 16 more
Caused by: org.xml.sax.SAXParseException: undefined attribute 'soapenc:arrayType'
        at
com.sun.xml.xsom.impl.parser.ParserContext$1.reportError(ParserContext.java:130)
        at
com.sun.xml.xsom.impl.parser.NGCCRuntimeEx.reportError(NGCCRuntimeEx.java:117)
        at com.sun.xml.xsom.impl.parser.DelayedRef.resolve(DelayedRef.java:90)
        at com.sun.xml.xsom.impl.parser.DelayedRef.run(DelayedRef.java:65)
        at
com.sun.xml.xsom.impl.parser.ParserContext.getResult(ParserContext.java:94)
        at com.sun.xml.xsom.parser.XSOMParser.getResult(XSOMParser.java:190)
        at com.sun.tools.xjc.ModelLoader.createXSOM(ModelLoader.java:487)
        at
com.sun.tools.xjc.api.impl.s2j.SchemaCompilerImpl.bind(SchemaCompilerImpl.java:203)
        at
com.sun.tools.xjc.api.impl.s2j.SchemaCompilerImpl.bind(SchemaCompilerImpl.java:67)
        at
com.sun.tools.ws.processor.modeler.wsdl.JAXBModelBuilder.bind(JAXBModelBuilder.java:126)
        ... 19 more
error: org.xml.sax.SAXParseException: undefined attribute 'soapenc:arrayType'

BUILD SUCCESSFUL (total time: 1 second)
Comment 1 lucyli 2006-10-02 22:48:33 UTC
Created attachment 34777 [details]
GoogleSearch.wsdl
Comment 2 lucyli 2006-10-02 22:51:44 UTC
This WSDL used to work with  Creator 2 and Creator 2 update 1 very well.
It fails with NB 5.5/VWP.
Comment 3 Petr Blaha 2006-10-03 08:21:11 UTC
I guess duplicate of issue #75671.
Comment 4 Milan Kuchtiak 2006-10-03 09:44:09 UTC
In order to understand this wsdl, JAX-WS requires to import the schema for
soapenc namespace:
<xsd:import namespace="http://schemas.xmlsoap.org/soap/encoding/"
schemaLocation="http://schemas.xmlsoap.org/soap/encoding/"/>

Then, however, the JAX-WS will refuse to generate client artifacts because wsdl
operations are RPC/encoded (see the error message).
This is,in fact, not a Netbeans issue. 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo