Bug 86253 - NetBeans blank UI with Xgl/Aiglx/Compiz enabled
NetBeans blank UI with Xgl/Aiglx/Compiz enabled
Status: RESOLVED DUPLICATE of bug 76641
Product: platform
Classification: Unclassified
Component: -- Other --
5.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
:
: 102423 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-30 18:10 UTC by hollywoodb
Modified: 2008-12-22 14:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hollywoodb 2006-09-30 18:10:23 UTC
Here are the versions I've tested:

NetBeans 5.0 on Sun JDK 5.0 update 7, 8, and 9
NetBeans 5.5beta2 on Sun JDK 5.0 update 7, 8, and 9.

All versions report the exact same error.  The NetBeans log looks just fine, and
the splash screen displays, then there is the NetBeans window with title and
icon in titlebar, but the UI itself is blank.  I can tell there are working
buttons under the blank UI because the cursor changes to a hand when I mouseover
them.  If I click the correct button I get a dialog box that says "Cannot
execute mozilla..." which displays correctly (I have firefox, but not mozilla or
seamonkey suite installed).

Here is the only error I can produce:

[hollywoodb@hb-130 ~]$ /opt/netbeans-5.5beta2/bin/netbeans 
java.net.UnknownHostException: hb-130.fedora: hb-130.fedora
        at java.net.InetAddress.getLocalHost(InetAddress.java:1308)
        at org.netbeans.CLIHandler.initialize(CLIHandler.java:487)
        at org.netbeans.CLIHandler.initialize(CLIHandler.java:291)
        at org.netbeans.Main.execute(Main.java:161)
        at org.netbeans.Main.main(Main.java:48)
[hollywoodb@hb-130 ~]$ 

I am running Fedora Core 6 test3, I have had this issue throughout the duration
of the FC6 test series, and now with FC6 release about two weeks away I have not
been able to resolve this issue, I've tried:

various kernels, various versions of NetBeans, various versions of Sun JDK 5.0,
completely disabling SELinux, letting SELinux do a filesystem relabel
post-install of JDK and NetBeans, attempting to run netbeans as a newly created
(unmodified) user, attemptint to run NetBeans as root.  Always the same error as
pasted above.

I can provide additional info as needed, just let me know what is needed. Thanks.
Comment 1 hollywoodb 2006-09-30 19:21:32 UTC
I fixed the unknown host error by adding:

127.0.0.1 hb-130.fedora hb-130  # 127.0.0.1 localhost.localdomian localhost

to /etc/hosts

Now I get no errors at all, but still a blank UI.  I've managed to click around
and open a few dialogs, like the new project dialog, but no matter what I do the
main window is still a blank window with a proper titlebar/window decor.
Comment 2 hollywoodb 2006-10-01 01:11:58 UTC
Alright I jumped the gun a little on this report, after banging my head for a
while today I decided why not run NetBeans under openbox in an Xnest?  Well
NetBeans worked fine.  The difference: AIGLX/Compiz.  Both NetBeans and Oracle's
JDevelop suffer from a blank UI with AIGLX/Compiz enabled.  Both work fine with
it disabled.  So I've found the culprit and would be willing to offer up
whatever I can if someone would like to work on this issue.
Comment 3 _ rkubacki 2006-10-02 22:23:37 UTC
Should CLIHandler be more fail safe?
Comment 4 unoengborg 2006-11-06 23:38:19 UTC
Turning AIGLX effects off and on again, in Fedora Core 6 makes the window reappear.

The java version used was:
java version "1.6.0-rc"
Java(TM) SE Runtime Environment (build 1.6.0-rc-b104)
Java HotSpot(TM) Client VM (build 1.6.0-rc-b104, mixed mode, sharing)

The JDK demo and other java programs runs without problems, so the problem seam
to be related to Netbeans rather than the prerelease java.

Comment 5 Marian Mirilovic 2006-11-07 08:40:54 UTC
this is duplicate of issue 76641
Look at that issue, there some hints and probably it will work for you as well:

1. removed 2 lines from file 'netbeans-5.0/platform6/lib/nbexec'. 
 J2D_PIXMAPS=shared
 export J2D_PIXMAPS

2. AWT_TOOLKIT=MToolkit in the environment fixes this

Please let us know which one works for you. Thanks in advance. 

*** This issue has been marked as a duplicate of 76641 ***
Comment 6 unoengborg 2006-11-07 17:54:48 UTC
Setting AWT_TOOLKIT=MToolkit in the environment helps, but is not enough.

You will also need to have the library libXp.so.6. Unfortunately this is
part of the xorg-x11-deprecated-libs package that no longer ships with
Fedora Core 6, and some other modern Linux distros.

Fedora Core 4 still contained libXp.so.6.2, so I copied that and made a
symbolic link, and now it works.

Other java apps seam to work, so preferably this should work out of the box.
Comment 7 Marian Mirilovic 2007-04-27 09:11:00 UTC
*** Issue 102423 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo