Bug 86114 - Cancel button works incorrect when dragging Web Service to BPEL
Cancel button works incorrect when dragging Web Service to BPEL
Status: CLOSED DUPLICATE of bug 84622
Product: soa
Classification: Unclassified
Component: BPEL
6.x
All All
: P3 (vote)
: -S1S-
Assigned To: Vladimir Yaroslavskiy
issues@soa
fix-in-60
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-29 09:11 UTC by Mikhail Kondratyev
Modified: 2009-04-07 22:08 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Kondratyev 2006-09-29 09:11:56 UTC
Steps to reproduce:
 - create a new Sync sample
 - create new Web Application, add a Web Service there
 - deploy web service
 - drag Web Service node to the BPEL process
 - PartnerLink editor will appear. Accept defaults
 - drag Web Service once more, press Cancel when the PartnerLink editor opens
 The PartnerLink created after first drag-N-drop will be marked invalid:
PartnerLinkType definition will be deleted from WSDL
Comment 1 Mikhail Kondratyev 2006-09-29 09:16:22 UTC

*** This issue has been marked as a duplicate of 84622 ***
Comment 2 Mikhail Kondratyev 2006-09-29 12:19:23 UTC
Verified in build 2006.09.27
Comment 3 Michael Frisino 2006-09-29 19:02:46 UTC
I don't think this is a duplicate of bug 84622. 

In that bug, the cancel is failing to delete the retrieved files, which was what
bug filer thinks should be done if there is no pre-existing PartnerLink.

In this case, the PartnerLink already exists, so the DnD should actually try to
allow user a chance to quit earlier - like "PartnerLink already exists for this
WSDL are you sure you want to overwrite. Y/N?" If this could be done before the
retrieval is invoked it would be best. This is tricky, since for EJB/WS we don't
have the WSDL yet. So check would have to be done against WS name if possible.

Anyway, this seems like a different use case and we should not lose track of it,
so I think it is worth keeping open and distinct from other use case.
Comment 4 Alexander Zgursky 2006-10-05 13:56:20 UTC
It is a UI issue - reassigning to Alexey
Comment 5 Sergey Lunegov 2007-10-25 11:45:04 UTC
Same as 84622
Comment 6 Andrei Chistiakov 2008-01-17 11:10:05 UTC
Changed target milestone from Sierra to 6.1 in order to display correct info on
NB 6.1 dashboard
Comment 7 Vladimir Yaroslavskiy 2009-03-02 10:41:23 UTC

*** This issue has been marked as a duplicate of 84622 ***
Comment 8 terrybraun 2009-04-07 22:08:21 UTC
Tested and closed with NetBeans IDE 6.5.1 (Build 200904031800).

QA believes this is not a duplicate of 84622, but this is not an issue at with this current build. Trying to drag an 
existing Web Service onto the Design View results in a validation message stating "A name for the new Partner Link Type 
has to be unique." Although the user can modify the name and then accept the "duplicate" Web Service WSDL, this seems 
to be a reasonable notification to the user.

A subsequent cancellation at the PartnerLink editor no longer deletes either of the existing WSDLs, and therefore fixes 
the symptom described.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo