Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 86087 - The Project window freezes
The Project window freezes
Status: RESOLVED DUPLICATE of bug 60235
Product: platform
Classification: Unclassified
Component: -- Other --
5.x
Macintosh Mac OS X
: P2 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 20:47 UTC by tino24
Modified: 2008-12-22 14:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (14.53 KB, text/plain)
2006-09-29 09:14 UTC, tino24
Details
thread dump after freezing (3.85 KB, text/plain)
2006-09-29 23:33 UTC, tino24
Details
~/.netbeans/5.5beta2/var/log/messages.log (242.77 KB, application/octet-stream)
2006-10-04 22:07 UTC, tino24
Details
/.netbeans/5.5beta/var/log/messages.log (15.13 KB, application/octet-stream)
2006-10-04 22:12 UTC, tino24
Details
~/.netbeans/5.0/var/log/messages.log (29.27 KB, application/octet-stream)
2006-10-04 22:14 UTC, tino24
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tino24 2006-09-28 20:47:24 UTC
Netbeans are still (about 5 times a day) freezing on my Mac
First freezes Project window (doesn't respond any mouse or keyboard events) and after a few seconds 
freezes editor window.
Only restart Netbeans solve this problem.
Comment 1 tino24 2006-09-29 09:14:31 UTC
Created attachment 34687 [details]
thread dump
Comment 2 tino24 2006-09-29 23:33:07 UTC
Created attachment 34729 [details]
thread dump after freezing
Comment 3 Marian Mirilovic 2006-10-03 14:09:47 UTC
Could somebody with Mac look at this issue ? I have no idea what's wrong from
the thread-dump ;(
Comment 4 Milos Kleint 2006-10-03 14:40:51 UTC
never happened on my mac. Please include your OS details.

in the first stacktrace it appears there is an ant build waiting for an external
process. What is happening in the build of yours?

Comment 5 Milos Kleint 2006-10-03 14:44:36 UTC
also please include the ~/.netbeans/{version}/var/log/messages.log file. It
might contains some additional information..
Comment 6 tino24 2006-10-04 21:56:44 UTC
I have tried versions 5 and 5.5 beta on Mac OSX 10.4.7, java 1.5.0_06
Comment 7 tino24 2006-10-04 22:07:50 UTC
Created attachment 34883 [details]
~/.netbeans/5.5beta2/var/log/messages.log
Comment 8 tino24 2006-10-04 22:12:43 UTC
Created attachment 34884 [details]
/.netbeans/5.5beta/var/log/messages.log
Comment 9 tino24 2006-10-04 22:14:06 UTC
Created attachment 34885 [details]
~/.netbeans/5.0/var/log/messages.log
Comment 10 Milos Kleint 2006-10-05 14:06:02 UTC
nothing really helpful in the log files. a few minor differences to my own setup

1. I have jdk Java HotSpot(TM) Client VM 1.5.0_06-55, you have a later build
Java HotSpot(TM) Client VM 1.5.0_06-64

2. you have
/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Classes/.compatibility/14compatibility.jar
on boot classpath

3. 2 additional modules in the ide: com.appliedmodels.mda.netbeans and
net.sf.springnetbeans.framework

4. a strange message saying: Post-initialization command-line options could not
be run.
But that should not be able to cause the freeze.

Comment 11 Milos Kleint 2006-11-22 10:53:52 UTC
please check issue #60235, this one could be a duplicate.

the issue sounds like the focus disappears in the app, that is primarily a bug
in apple's jdk. The issue #60235 shows some situation when this can happen and
also lists the jdk version that should have the behaviour improved.
Comment 12 Milos Kleint 2007-08-17 10:21:26 UTC
I haven't encountered the issue for rather a long time. No new similar issuezilla reports were filed for some time either.
using this JDK version now:
Java: 1.5.0_07; Java HotSpot(TM) Client VM 1.5.0_07-87


I believe this issue is duplicate of #60235, closing as such




*** This issue has been marked as a duplicate of 60235 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo