Bug 85919 - Deadlock when editing java source (from OccurrencesMarkProvider)
Deadlock when editing java source (from OccurrencesMarkProvider)
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jan Lahoda
issues@java
: THREAD
: 89395 90474 90578 (view as bug list)
Depends on:
Blocks: 87136
  Show dependency treegraph
 
Reported: 2006-09-27 17:42 UTC by Petr Hrebejk
Modified: 2007-01-17 10:09 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
threaddump (18.68 KB, application/octet-stream)
2006-09-27 17:42 UTC, Petr Hrebejk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hrebejk 2006-09-27 17:42:03 UTC
A deadlock occured when editing a java souce file. More precisely, I was
adding a new method to an existing class. Its trace is different from issues
164,165,242.

Found one Java-level deadlock:
=============================
"AWT-EventQueue-1":
waiting to lock monitor 0x000dd4d0 (object 0xc663a348, a
org.netbeans.modules.java.editor.semantic.OccurrencesMarkProvider),
which is held by "Java Source Worker Thread"
"Java Source Worker Thread":
waiting to lock monitor 0x000dd5a8 (object 0xc65c2700, a
org.netbeans.modules.editor.errorstripe.AnnotationViewDataImpl),
which is held by "AWT-EventQueue-1"

Java stack information for the threads listed above:
===================================================
"AWT-EventQueue-1":
at
org.netbeans.modules.java.editor.semantic.OccurrencesMarkProvider.getMarks(OccurrencesMarkProvider.java:57)
- waiting to lock <0xc663a348> (a
org.netbeans.modules.java.editor.semantic.OccurrencesMarkProvider)
...
(whole trace attached)

----
netbeans-retouche-200608050000.zip
NetBeans IDE Dev (Build 060805)
1.5.0_07; Java HotSpot(TM) Client VM 1.5.0_07-b03
SunOS version 5.10 running on sparc
en (nb); ISO646-US
Comment 1 Petr Hrebejk 2006-09-27 17:42:42 UTC
Created attachment 34601 [details]
threaddump
Comment 2 Jan Lahoda 2006-12-01 16:02:06 UTC
*** Issue 89395 has been marked as a duplicate of this issue. ***
Comment 3 Jan Lahoda 2006-12-04 09:38:53 UTC
*** Issue 90474 has been marked as a duplicate of this issue. ***
Comment 4 Jan Lahoda 2006-12-06 09:45:34 UTC
*** Issue 90578 has been marked as a duplicate of this issue. ***
Comment 5 Jan Lahoda 2006-12-06 09:47:59 UTC
Hopefully fixed:
Checking in OccurrencesMarkProvider.java;
/cvs/java/editor/src/org/netbeans/modules/java/editor/semantic/OccurrencesMarkProvider.java,v
 <--  OccurrencesMarkProvider.java
new revision: 1.3; previous revision: 1.2
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo