Bug 85361 - [Vista] Installer does not start
[Vista] Installer does not start
Status: RESOLVED WORKSFORME
Product: installer
Classification: Unclassified
Component: Code
5.x
PC Windows Vista
: P2 with 1 vote (vote)
: 5.x
Assigned To: mslama
issues@installer
Vista
: RELNOTE
: 85102 88291 90601 95886 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-20 16:58 UTC by Max Sauer
Modified: 2007-07-09 12:01 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
installer log file (3.65 KB, text/plain)
2006-09-25 08:47 UTC, Max Sauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Max Sauer 2006-09-20 16:58:07 UTC
Inside Windows Vista RC1, the installer of NB5.5 does not start, a message
suggesting running with "silent" or "console" flag appears. This may be also
caused by using AeroGlass graphic mode.

P1 because we're late in developement cycle.

---
Product Version         = NetBeans 5.5 Dev (Build 200609200300)
Operating System        = Windows NT (unknown) version 6.0 running on x86
Java; VM; Vendor; Home  = 1.5.0_09; Java HotSpot(TM) Client VM 1.5.0_09-b01; Sun
Microsystems Inc.; D:\jdk\jdk1.5.0_09\jre
System Locale; Encoding = cs_CZ (nb); Cp1250
WindowsVista RC1 Build 5600
netbeans-5_5-daily_dev-bin-200609200300-windows-20_Sep_2006_0300.exe
Comment 1 Max Sauer 2006-09-25 08:47:42 UTC
Created attachment 34445 [details]
installer log file
Comment 2 Max Sauer 2006-09-25 08:57:45 UTC
I've attached log file from:
netbeans-5_5-daily-bin-200609250000-windows-25_Sep_2006_0000.exe -is:l
og installer.log -is:javahome "C:\Program Files\Java\jdk1.6.0"

There is an exception stack trace inside:

(Sep 25, 2006 9:45:53 AM), Install,
com.installshield.wizard.StandardWizardListener, dbg,
java.lang.ArrayIndexOutOfBoundsException: 3136

java.lang.ArrayIndexOutOfBoundsException: 3136

	at sun.awt.shell.Win32ShellFolder2.getFileChooserIcon(Win32ShellFolder2.java:800)

	at sun.awt.shell.Win32ShellFolderManager2.get(Win32ShellFolderManager2.java:274)

	at sun.awt.shell.ShellFolder.get(ShellFolder.java:218)
...
(whole stack trace attached)

---
JDK:
java version "1.6.0-rc"
Java(TM) SE Runtime Environment (build 1.6.0-rc-b99)
Java HotSpot(TM) Client VM (build 1.6.0-rc-b99, mixed mode, sharing)
Comment 3 mslama 2006-09-26 07:37:59 UTC
Confirmed. I filed issue #6474738 against Swing. Workaround is to use command
line option -is:extract to extract setup.jar from installer. Then run "java -jar
setup.jar". Unfortunately there is problem with running external process from
installer due to strict security policy in Windows Vista RC1 => installer fails
anyway. I am investigating it now and will file new issue.
Comment 4 mslama 2006-09-26 07:39:20 UTC
*** Issue 85102 has been marked as a duplicate of this issue. ***
Comment 5 mslama 2006-09-26 08:25:58 UTC
If User Account Control is turned on installer fails. I filed separate issue
#85739 to handle this behavior somehow.
Comment 6 Lukas Hasik 2006-09-27 09:33:18 UTC
this applies to all installers (e.g. Mobility Pack ...) 
should I file separate issue or will you fix all the installers?
Comment 7 Petr Blaha 2006-09-27 09:37:29 UTC
I downgrading priority to P2 since Vista isn't supported platform yet.
Comment 8 Antonin Nebuzelsky 2006-09-27 11:20:19 UTC
Will send a waiver request.

This should be IMO mentioned in Release Notes together with issue 85739.
Comment 9 mslama 2006-10-04 12:30:16 UTC
Info for release notes (the same as in issue #85739):
Installer must be run on JDK 6.0 build 96 and newer. Also Compatibility mode
must be disabled. (Vista sets compatibility mode for installer exe automaticaly.
It must be switched off manually in File Properties -> Compatibility tab.) Then
installer exe runs fine even if UAC is enabled.
Comment 10 mslama 2006-10-04 15:50:57 UTC
I review current status of our understanding of all issues here:
First it is for Vista RC1 build 5600.
There are 2 problems with JDK on Vista:
1. #6449933 Problem with JFileChooser. It is fixed in JDK 6.0 b96.
2. #6474738 It is similar to problem 1 (so it took some time we found it is not
the same) and is caused by running installer exe in compatibility mode for Win
XP. (For some reason Vista decides to run installer exe in this compatibility
mode.) It causes incorrect OS version returned by native method GetVersion() and
as JDK code does not handle case that program running on Vista can return
incorrect OS version it causes crash. Workaround is to switch off compatibility
mode manualy for installer exe.

Conclusion: We need to run installer in JDK 6.0 b96 and newer due to problem
[1]. We need to switch off compatibility mode manually for installer exe to
workaround problem [2]. If we follow this installer exe runs fine even if UAC is
enabled. (In issue #85739 we found that UAC prevents running some installer
background task when installer is run using "java -jar setup.jar".)

Comment 11 artibee 2006-10-05 16:09:38 UTC
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6449933
-- Fixed in Build96

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6474738
-- ArrayIndexOutOfBoundsException

Comment 12 Max Sauer 2006-10-09 13:02:31 UTC
The installer runs correctly on Windows Vista RC2, with UAC turned on.

---
Vista RC2 b5744
Netbeans 5.5RC1
JDK 1.6.0 b100
Comment 13 Max Sauer 2006-10-09 13:19:25 UTC
This seems to be becouse of compatability mode is OFF by default in RC2.
Comment 14 swhitehead 2006-10-13 15:35:01 UTC
Installer continues to fail.  Followed suggestions under the release notes
(turned compatibility off, even tried it with it on).

Silient installation works but when ever I try to click open project it get:
java.lang.ArrayIndexOutOfBoundsException: 3184
	at sun.awt.shell.Win32ShellFolder2.getFileChooserIcon(Win32ShellFolder2.java:800)
	at sun.awt.shell.Win32ShellFolderManager2.get(Win32ShellFolderManager2.java:274)

Which has been noted to be fixed in b96, but is still causing issues

Microst Windows Vista Ultimate, 6.0.5600 Build 5600

java version "1.6.0-rc"
Java(TM) SE Runtime Environment (build 1.6.0-rc-b102)
Java HotSpot(TM) Client VM (build 1.6.0-rc-b102, mixed mode, sharing)
Comment 15 swhitehead 2006-10-13 16:00:16 UTC
Was able to resovle the file chooser issue.  After spending much time trying to
figure out why netbeans "appeared" to be running in "compatibility" mode even
though the short cut properties were disabled, the exe properties where disabled
and java*.exe were disabled I checked the "show settings for users" which
appeared to be set to Windows XP.

Appologies
Comment 16 swhitehead 2006-10-13 16:02:06 UTC
Also checked the installer, same conclusion.  The top level properties were
disablled, but the "Show settings for all users" were still enabled
Comment 17 droida38 2006-11-30 10:40:54 UTC
When trying to install Netbeans 6 (28.11.06) on Vista, the installer exits 
when it's about to copy files.
C:\program files\netbeans 6.0 dev has been created but contains 0 files.

When looking at catalog properties for "c:\program files\netbeans 6.0" it 
appears to be writeprotected. Removed the writeonly flag and tried again - 
with success
Comment 18 droida38 2006-11-30 10:41:51 UTC
When trying to install Netbeans 6 (28.11.06) on Vista, the installer exits 
when it's about to copy files.
C:\program files\netbeans 6.0 dev has been created but contains 0 files.

When looking at catalog properties for "c:\program files\netbeans 6.0" it 
appears to be writeprotected. Removed the writeonly flag and tried again - 
with success
Comment 19 mslama 2006-11-30 10:56:14 UTC
Please  file separate issue for copy problem. Installer creates target directory
if it does not exist yet. If new directory is created access right should be
correct. At least we did not enocunter any such problem. If directory already
exists it might have incorrect access rights. Also add which Vista build you use
and what JDK version/build is used to run installer.
Comment 20 mslama 2006-12-07 10:26:16 UTC
*** Issue 90601 has been marked as a duplicate of this issue. ***
Comment 21 mslama 2006-12-07 10:51:14 UTC
*** Issue 88291 has been marked as a duplicate of this issue. ***
Comment 22 mslama 2007-02-22 12:39:45 UTC
*** Issue 95886 has been marked as a duplicate of this issue. ***
Comment 23 mslama 2007-07-09 12:01:29 UTC
No more reports. 1. JDK already fixes firts problem. 2. Vista FCS does not set compatibility mode for installer automaticly.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo