Bug 84622 - Canceling the PL dialog after DnD of a Web Service does not rollback properly
Canceling the PL dialog after DnD of a Web Service does not rollback properly
Status: CLOSED FIXED
Product: soa
Classification: Unclassified
Component: BPEL
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Vladimir Yaroslavskiy
issues@soa
55EP_RR_WAIVED , 55EP_RR_DOCS , UI
:
: 86114 (view as bug list)
Depends on:
Blocks: 124234
  Show dependency treegraph
 
Reported: 2006-09-11 16:00 UTC by Jiri Kopsa
Modified: 2009-11-08 09:28 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Kopsa 2006-09-11 16:00:12 UTC
This is a follow up on:
http://www.netbeans.org/issues/show_bug.cgi?id=83495

Cancelling the PL dialog that pops up when a Web Service is DnDed on the BPEL
diagram should rollback to the state before the gesture.

This is not happening as copied files (and perhaps other artifacts) are left in
the BPEL project.
Comment 1 Michael Frisino 2006-09-12 12:54:39 UTC
I recommend we waive this for this release. We have other more important issues
to focus on in my opinion. Use case for canceling the DnD should be fairly rare
and the obvious workaround is for user to simply delete the new folder that was
created by the DnD. This is not a difficult or obscure workaround. Automatically
removing the files will requre a higher understanding of the pre DnD state than
we currently have at our disposal.
Comment 2 Michael Frisino 2006-09-12 13:02:25 UTC
Recommend documentation contain note to effect that

"The DnD of references ( wsdl file, or Web Service node) from one NetBeans
project onto a BPEL Module diagram causes several effects to take place. These
effects include the automated "retrieval" of the dragged source object's WSDL
file(s). Cancelation of the DnD operation does not roll back the retrieval of
these files(s). If these files are not needed by the project, simply delete
these files manually from the project explore tab, as you would delete any other
project resource."

Comment 3 Jiri Kopsa 2006-09-12 13:41:32 UTC
I have no problem with waiving of this bug. Just please, let's keep this open so
we don't forget and can work on that later ... 
Comment 4 Michael Frisino 2006-09-16 07:38:35 UTC
we can change its status to Later after it is waived I suppose.
Comment 5 Mikhail Kondratyev 2006-09-29 09:16:22 UTC
*** Issue 86114 has been marked as a duplicate of this issue. ***
Comment 6 astashkova 2006-10-19 16:25:16 UTC
Added to NetBeans Enterprise Pack 5.5 Release Notes as follows:

IDE does not roll back the retrieval of the WSDL files(s) after you cancel the
PartnerLink dialog. Description: If you cancel the PartnerLink dialog that
appears when you drag a WSDL file or a Web Service node from a NetBeans project
onto a diagram, the IDE does not roll back the retrieval of the WSDL files(s).

Workaround: If these files are not needed by the project, simply delete them
manually from the Projects window, as you would delete any other project resource.

(http://nbstaging.czech/community/releases/55/entpack_relnotes.html#84622) 
Comment 7 Victoria Zhukovskaya 2007-02-08 11:32:15 UTC
Orch Project has Folder Prtners and wsdl/xsd files
Comment 8 Jiri Prox 2007-09-17 20:19:50 UTC
Obsolete milestone, please reevaluate
Comment 9 Jiri Kopsa 2007-09-18 18:27:55 UTC
I'm not on the project anymore. Please reassign or close.
Comment 10 Sergey Lunegov 2007-10-25 11:43:24 UTC
Should consider as part of "swim lanes" feature in Sierra.
Comment 11 Andrei Chistiakov 2008-01-17 11:08:32 UTC
Changed target milestone from Sierra to 6.1 in order to display correct info on
NB 6.1 dashboard
Comment 12 Alexey Yarmolenko 2008-02-21 14:35:31 UTC
I believe, this problem comes from the fact, that we have 2 heavy-weight actions on one user gesture: 
1. retrieving wsdl files to our project and 
2. adding PL to diagram.
1st step is hard to rollback because it it involves copying a lot of files and some of them may override old versions.
Rolling back such operations is impossible if we don't have support from filesystem level. Also there is another problem
with this step: user is poorly informed about what goes on behind the scene - were dropped files actually copied or just
linked and where we store them locally. 

The logical solution for me is to separate these 2 steps: First user should drag wsdl or EJB WS node and drop it on a
folder inside current project. This will invoke retriever and user will see new wsdl and auxiliary files to appear in
the folder where they were dropped. User will get a chance to go and take a look what kind of definitions are stored in
retrieved files and what needs to be created to make these files usable in our bpel process.

Then user can drag this wsdl from project folder to diagram. This will result in PL customizer dialog to appear and new
PL created. 

Old gesture(dropping wsdls to diagram directly) will be interpreted as "create PL by adding reference", if wsdl was
dragged across the project boundaries, we will use catalog and project dependencies to access it later.

p.s. Doing so we also will fix 124234.
Comment 13 Alexey Yarmolenko 2008-02-21 14:38:24 UTC
I suggest to waive this beta, because fix is quiet complicate and affects other functions.
Comment 14 Vladimir Yaroslavskiy 2009-03-02 10:39:38 UTC
Referenced resources are used instead of copy,
so there is no retrieval to Partners folder.
Comment 15 Vladimir Yaroslavskiy 2009-03-02 10:41:17 UTC
*** Issue 86114 has been marked as a duplicate of this issue. ***
Comment 16 terrybraun 2009-04-07 22:28:15 UTC
Fix Rejected -

After draging the Web Service on to the swimlane, two things are current done:

a) the PartnerLink editor is displayed for "Ok" or "Cancel".
b) the WSDL is stored as a "Referenced Resource" in the new project.

If the user clicks "Cancel", the Referenced Resource is not removed, and the project is not rolled back to its original 
state.

[QA suspects that the Referenced Resource addition to the project should be added only after "Ok" at the PartnerLink 
editor.]
Comment 17 Vladimir Yaroslavskiy 2009-07-15 12:09:38 UTC
Behaviour is correct:

When user drag and drop a Web Service from EJB module on BPEL diagram,
referenced resource to the service is created and only after that the PL
dialog is shown.

Adding of the referenced resource is the result of drop action and can't
be rolled back. The referenced resource must be created before the PL
dialog to be shown in the whole list of services. The PL dialog can't
roll back the referenced resources.
Comment 18 terrybraun 2009-10-07 17:33:51 UTC
Since this issue will not be fixed and the explanation is acceptable, QA acknowledges and closes this ticket.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo