Bug 84512 - OutOfMemoryError for mysql project
OutOfMemoryError for mysql project
Status: RESOLVED DUPLICATE of bug 78222
Product: cnd
Classification: Unclassified
Component: Code Model
5.x
All All
: P1 (vote)
: 6.x
Assigned To: Egor Ushakov
issues@cnd
CND1-FCS parser
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-08 13:16 UTC by Maria Tishkova
Modified: 2006-10-12 13:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maria Tishkova 2006-09-08 13:16:55 UTC
Mysql5.0.18 cannot be openen as MakefileProject when netbeans is run with the
following parameters:

-J-XX:+HeapDumpOnOutOfMemoryError -J-Dnetbeans.logger.console=false -J-ea
-J-server -J-Xmx512M -J-Xms256M 

OutOfMemoryError occured


------------------------

It is possible to open mysql if -J-Xmx1024M option is used


values of memory:

apt.dispose.tokens=false:

755/1012M

after gc:

606/1012M

apt.dispose.tokens=true:

584/877

after gc:

458/877
Comment 1 _ rkubacki 2006-10-11 14:41:11 UTC
Might be interesting when fixing this problem -
http://wiki.netbeans.info/wiki/view/FaqNetBeansAndOOME
Comment 2 Egor Ushakov 2006-10-12 13:09:11 UTC

*** This issue has been marked as a duplicate of 78222 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo