Bug 8407 - Sources not saved and rebuilded when Executing project!
Sources not saved and rebuilded when Executing project!
Status: CLOSED FIXED
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
3.x
PC Windows 3.1/NT
: P1 (vote)
: 3.x
Assigned To: Jan Pokorsky
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-14 12:10 UTC by tkellerer
Modified: 2003-07-01 14:18 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tkellerer 2000-11-14 12:10:19 UTC
I have files loaded from a CVS filesystem, and when I hit Execute (F6) while
my changes are not saved, the editor will not save the file, thus it gets not
compiled and the old class file is executed.

This happens with Dev Build 66 and up, as well as with 3.1 build 5
Comment 1 Martin Entlicher 2000-11-22 16:15:59 UTC
I test it in #75 build and it works fine.
Be sure, that you don't have mounted a file of the same name twice. That may
cause, that the IDE is trying so save the second file (which is saved, so
nothing happens).
Comment 2 tkellerer 2000-11-30 15:45:59 UTC
>>Be sure, that you don't have mounted a file of the same name twice
I'm sure of that...

I'm using the CVS filesystem thoug. Does that influence the behaviour?

Ctrl-F6 seems to save the file before executing, whereas F6 doesn't
I just tried the following with 31.beta Build 16 and it still doesn't save
Situation: Editor window completely closed
Select a source file (with a main method)
Choose CVS/Edititing/Edit from the context menu
Doubleclick on the file to open the editor
Change something
Hit F6
--> File is executed but not saved before

The class files are not inside the same directory structure as the source files!
Comment 3 tkellerer 2001-03-15 15:25:17 UTC
Well I just tested it with 3.2 build 5 and I still have that problem.

My scenario:
Mount a CVS file system (not the new JavaCVS)
Make sure you check out files read only.
Open a file.
Issue the CVS/Edit command for that file
Edit something inside the file (do not save!)
Press Shift-F6 to execute the project, the file will not be saved
(maybe it has something to do with the read only flag?)

Comment 4 Jan Lahoda 2001-03-16 18:20:34 UTC
From Product settings I suppose this belongs to core. I am settings Assigned to
filed to reflect this. If I am wrong, change it.
Comment 5 tkellerer 2001-04-19 09:31:42 UTC
This is still an issue with 3.2 build 32. This also happens with files 
from a CVS file system where the option "Check out files readonly" is
not checked. 

As I have said before: this only happens when executing the project, not when 
executing a class with a main method directly (via Build/Execute or F6) in that 
case the file is saved and compiled properly.

I think this is a major issue! This should get a higher priority (a colleague of 
mine just spent several minutes on this because his changes were not working and 
it turned out that the reason was that the file was not saved and compiled 
before runnnig the project...)
Comment 6 Jan Zajicek 2001-04-19 16:13:15 UTC
So, after a small investigation I found following behaviour (the relation to the
cvs is irelevant, the behaviour is global):

When you create some project that contains several source files, delegate a main
class and work on it (it means you have opened more files in the editor and some
are changed). Then note that, when project main class is unmodified while some
others are and you execute project (Ctrl+Shift+F6) the modified sources are not
saved and recompiled! Moreover when you clean the project and then exetcute it,
it is not rebuild and CNF is thrown.

Workaround is: before execution explicitly rebuild the project. So increasing
priority to P2, because the project execution does not work properly even the
simple workaround exists. If you think that impact is smaller than P2 then
please decrease, but I think that this should be fixed in 3.2 FCS.
Comment 7 Jaromir Uhrik 2001-04-20 14:22:09 UTC
Changing priority to P1. Should be really fixed in 3.2 FCS.
Comment 8 Jan Pokorsky 2001-04-20 15:54:30 UTC
I have prepared a fix. I will commit it to the trunk and the release32 ASAP. It 
is just partial rollback of #9931.
Comment 9 Jan Pokorsky 2001-04-20 16:39:41 UTC
Fixed to the trunk.

Diff:
http://www.netbeans.org/unbranded-source/browse/projects/src/org/netbeans/module
s/projects/PSupport.java.diff?r1=1.59&r2=1.60
Comment 10 Jan Pokorsky 2001-04-21 17:17:27 UTC
Fixed to the release32 branch.
Comment 11 Jan Zajicek 2001-04-23 13:09:24 UTC
NB3.2 build #36
Comment 12 Jan Chalupa 2001-05-06 14:27:17 UTC
Target milestone -> 3.2
Comment 13 Quality Engineering 2003-07-01 14:18:24 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo