Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 83610 - Deleting mulitple nodes fails in column view
Deleting mulitple nodes fails in column view
Status: VERIFIED WORKSFORME
Product: xml
Classification: Unclassified
Component: Schema Tools
5.x
All All
: P3 (vote)
: TBD
Assigned To: Ayub Khan
issues@xml
55EP_RR_WAIVED , 55EP_RR_DOCS
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-28 18:17 UTC by Nathan Fiedler
Modified: 2007-04-05 16:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan Fiedler 2006-08-28 18:17:48 UTC
Open the purchase order or loan application sample schemas, and using the column
view, find and select multiple nodes (e.g. elements in a sequence). Right-click
and select Delete from the context menu -- only one of the nodes is actually
removed, the others simply remain selected. Now try the same in the tree view --
it works fine, all selected nodes are removed.

Seems there is a problem with the column view and performing an action on
multiple nodes.
Comment 1 Nathan Fiedler 2006-08-30 19:11:23 UTC
I just noticed this is not always reproducable (on Windows, may still happen all
the time on Solaris, where I originally noticed the problem). It seems to fail
the first time, but subsequent attempts to delete multiple nodes are successful.
Comment 2 bhate 2006-09-20 19:07:52 UTC
Nathan,
It works fine for me on solaris 9 jdk 1.5.0_07.
Can you retest?
closing not reproducible.
Comment 3 Nathan Fiedler 2006-09-20 19:13:51 UTC
It must be specific to either Solaris 10, Solaris x86, or GNOME. The problem
still occurs for me on Solaris 10 x86 using the GNOME desktop. Also, my comment
about the problem disappearing after the first attempt is incorrect -- deleting
multiple components never works as expected, in the column view mode. Tree view
mode is okay.
Comment 4 bhate 2006-09-21 19:26:05 UTC
This issue probably happens only on Solaris 10, Solaris x86, or GNOME.
Workarounds for user
Multi select and use delete key
single select and use context menu delete
use tree editor
Comment 5 Nathan Fiedler 2006-09-26 21:12:21 UTC
FYI, I just reproduced this problem using a local build from today, on my
Windows XP machine. So this is indeed _not_ specific to Solaris or Unix. The
problem is, it is not always reproducable.
Comment 6 htt 2006-09-26 21:25:02 UTC
Also reproducible in the latest CB 060926_10 on Solaris 9 sparc & Linux FC3 with
jdk1.5.0_09.
Comment 7 astashkova 2006-10-23 12:40:44 UTC
Added to RNs.
Use the following link to review the wording and location of the issue in the
staged Release Notes
http://nbstaging.czech/community/releases/55/entpack_relnotes.html#83610
Comment 8 Ayub Khan 2007-01-16 21:11:05 UTC
I could not reproduce the issue in Windows XP (nb release551 locally build) and
JDK 1.6.0_b2. In my opinion this should be a P4 bug, and possible RN target.
Comment 9 Mikhail Matveev 2007-04-05 16:16:18 UTC
99901 is a similar issue for current (6.0) version. So this issue should be
closed anyway, and I mark it as verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo